数学建模社区-数学中国

标题: SQL Server连接失败错误及解决 [打印本页]

作者: 韩冰    时间: 2004-11-19 10:28
标题: SQL Server连接失败错误及解决
在使用 SQL Server 的过程中,用户遇到的最多的问题莫过于连接失败了。一般而言,有以下两种连接 SQL Server 的方式,一是利用 SQL Server 自带的客户端工具,如企业管理器、查询分析器、事务探查器等;二是利用用户自己开发的客户端程序,如ASP 脚本、VB程序等,客户端程序中又是利用 ODBC 或者 OLE DB 等连接 SQL Server。下面,我们将就这两种连接方式,具体谈谈如何来解决连接失败的问题。! B$ C. N" D- j0 ?$ v) G$ p/ {+ `
% L" ^" Y. j8 f. |' z0 o. Y! t
  一、客户端工具连接失败
' Q( B& e* c0 l
1 y- c7 e/ a2 @  在使用 SQL Server 自带的客户端工具(以企业管理器为例)连接 SQL Server时,最常见的错误有如下一些:' w. y2 T. _1 w+ U
  Q0 o/ s7 m/ D0 S
  1、SQL Server 不存在或访问被拒绝* y6 J, r% s% q; U

6 T, a0 a+ b4 m    ConnectionOpen (Connect())
7 B6 u7 A8 A( y8 t1 s, u
, Y2 R) g9 s( Y# H# g  7 x, q9 D, H, y0 F# y* S% L

% P$ J* S) m: j1 \+ ?& B' G+ {, ?( K/ e; J
! z8 b' ~$ _, g  {2 g7 S$ V
2 I5 M4 Y8 i$ b# n
  2、用户'sa'登录失败。原因:未与信任 SQL Server 连接相关联。1 R. U& s0 W: w- J. r3 \: q) S4 V

) F0 g3 ^/ p  s  * V, y( p% {+ [1 V% M, c1 F
& L, }" H- Q1 l; W+ U* C

  b5 q" P0 b4 y6 i: Q: U
+ H, _7 e5 E7 C  D! u( u/ O/ {" A+ S! Z& v) h# D, m: B
  3、超时已过期。
0 `( |: b- d  y( f( c
$ Z0 N. M9 B0 `' R# _" ?   % |" T4 s0 S6 y4 \

( M& L" s8 q: w/ P
4 n& Z0 R. ?5 u  ~1 X下面我们依次介绍如何来解决这三个最常见的连接错误。
$ r( `, B* G! J2 k
3 X" d# l% G# J4 C( l  第一个错误"SQL Server 不存在或访问被拒绝"通常是最复杂的,错误发生的原因比较多,需要检查的方面也比较多。一般说来,有以下几种可能性:7 w1 O/ X, k4 S  T* F. B" `
# \# U1 q/ [. ~- ^) ?0 ^4 P
  1、SQL Server名称或IP地址拼写有误;( J3 J+ i& l/ o' d& O% e7 w3 g8 g

" t* o6 M2 N% V6 W) |0 r- T  2、服务器端网络配置有误;
* u0 x! R, ]4 r) Y# J& T
! X8 Y+ e+ `6 ]  3、客户端网络配置有误。& Y- b# j- g+ Z! `
) m5 H1 j4 Z5 d8 a
  要解决这个问题,我们一般要遵循以下的步骤来一步步找出导致错误的原因。
) g9 a2 G$ Z1 o" X( U/ p7 Q# a
4 N8 U; }" K4 l/ n7 O; _& p  首先,检查网络物理连接:
1 c9 ]! w; ]* }* a; I4 f+ o3 O1 O( J
   ping <服务器IP地址>
& ~0 I, R5 e( r8 _! T ( @- c  \, G  {( O' A3 K9 a3 k
  或者5 C# ~: A9 c- ~6 {# b& U- |1 j

2 i  w) i! E0 X7 ^( g   ping <服务器名称>3 o7 p$ W1 u4 n3 b" l
& N& Y4 V8 y& r5 X
  如果 ping <服务器IP地址> 失败,说明物理连接有问题,这时候要检查硬件设备,如网卡、HUB、路由器等。还有一种可能是由于客户端和服务器之间安装有防火墙软件造成的,比如 ISA Server。防火墙软件可能会屏蔽对 ping、telnet 等的响应,因此在检查连接问题的时候,我们要先把防火墙软件暂时关闭,或者打开所有被封闭的端口。: K+ ~7 U' M( e" T5 q; d
- o- `0 d; W, j% A7 x, f
  如果ping <服务器IP地址> 成功而 ping <服务器名称> 失败,则说明名字解析有问题,这时候要检查 DNS 服务是否正常。有时候客户端和服务器不在同一个局域网里面,这时候很可能无法直接使用服务器名称来标识该服务器,这时候我们可以使用HOSTS文件来进行名字解析,具体的方法是:
4 n1 w8 G8 h/ x3 {! F
7 o4 Q  |, O  d+ s2 j( |  1、使用记事本打开HOSTS文件(一般情况下位于C:\WINNT\system32\drivers\etc).( T! ^$ h; X% F7 q* w; q
( V7 P. R; Z, D# K
  2、添加一条IP地址与服务器名称的对应记录,如:  b# I3 Q3 R# F
% i8 Y6 [# m+ Z  I0 O1 X
    172.168.10.24 myserver; \* H) d, `( R: U4 u6 T

- ~$ t% h7 b1 ~4 l. ?3 Q  也可以在 SQL Server 的客户端网络实用工具里面进行配置,后面会有详细说明。
: C3 X' T8 f* B0 X- J( w7 X" E) l$ z; d
  其次,使用 telnet 命令检查SQL Server服务器工作状态:% P* y6 X$ P% C6 d

; T9 g4 {3 c. X, {   telnet <服务器IP地址> 1433
9 ?- t  y% y) @5 ^3 Y! t
: G* f) S, R$ s  如果命令执行成功,可以看到屏幕一闪之后光标在左上角不停闪动,这说明 SQL Server 服务器工作正常,并且正在监听1433端口的 TCP/IP 连接;如果命令返回"无法打开连接"的错误信息,则说明服务器端没有启动 SQL Server 服务,也可能服务器端没启用 TCP/IP 协议,或者服务器端没有在 SQL Server 默认的端口1433上监听。% P5 W( d! O; a! o4 Q& f
6 F" z* ?  i$ h" _* x% V
  接着,我们要到服务器上检查服务器端的网络配置,检查是否启用了命名管道,是否启用了 TCP/IP 协议等等。我们可以利用 SQL Server 自带的服务器网络使用工具来进行检查。
% X: S9 b0 M5 Z2 M2 |( r) ~5 ?2 z: i, V6 @; h1 @
  点击:程序 -> Microsoft SQL Server -> 服务器网络使用工具,打开该工具后看到的画面如下图所示:1 B2 Y6 I) I& ?$ `' w, e' y
$ h) L. S) g) S3 J+ V
  $ B' j' A! |/ n5 t$ w

* @$ f4 _/ j5 r" v# a* {% p  {  n  b4 n/ x6 x" ]' ^
  从这里我们可以看到服务器启用了哪些协议。一般而言,我们启用命名管道以及 TCP/IP 协议。% b6 L9 r4 }) e% z
8 ]! V% ^4 K7 U9 o
  点中 TCP/IP 协议,选择"属性",我们可以来检查 SQK Server 服务默认端口的设置,如下图所示:
) b- n" P; h' ^3 `& R4 D/ Q+ K5 G" S  X' _. R; s* M" c0 s4 E3 T
  
" C( Y  X! o: e8 ^' [5 p
9 [) h' W6 {/ j8 t$ T2 o3 z7 W$ N
/ n/ D; b/ Q( c1 l) m5 D

' c  z3 S5 l% s  一般而言,我们使用 SQL Server 默认的1433端口。如果选中"隐藏服务器",则意味着客户端无法通过枚举服务器来看到这台服务器,起到了保护的作用,但不影响连接。
- `7 `$ x+ F1 E; ^& N" {
+ W3 I- E, @, `4 q  检查完了服务器端的网络配置,接下来我们要到客户端检查客户端的网络配置。我们同样可以利用 SQL Server 自带的客户端网络使用工具来进行检查,所不同的是这次是在客户端来运行这个工具。5 p: }/ q+ o" L& _( ]
/ _  W' |" @& e* G1 d
  点击:程序 -> Microsoft SQL Server -> 客户端网络使用工具, 打开该工具后看到的画面如下图所示:
% b4 o( N1 n2 f
8 w0 a; a! d% Z+ P" a  ( F$ f7 q0 I6 L- m' t

4 R% }. f+ N+ F$ e1 @  p; N' ^- [5 O5 i6 P( q- e
  从这里我们可以看到客户端启用了哪些协议。一般而言,我们同样需要启用命名管道以及 TCP/IP 协议。( j( z0 `# y3 y, q9 U

0 _8 N/ g5 k. s/ m1 V7 ~8 ~  f  点击 TCP/IP 协议,选择"属性",可以检查客户端默认连接端口的设置,如下图所示。
& j7 h  x2 b* z5 i1 D% H4 e0 U: h' \0 Z7 A1 K) ~
  - F  y! L$ v7 {- c1 N# h- ~
1 l' R; T- s/ w; A) s' n) F/ j
. O% y0 {4 ]% `5 N. q( t* l9 O5 N
  该端口必须与服务器一致。
作者: 韩冰    时间: 2004-11-19 10:28
单击"别名"选项卡,还可以为服务器配置别名。服务器的别名是用来连接的名称,连接参数中的服务器是真正的服务器名称,两者可以相同或不同。如下图中,我们可以使用myserver来代替真正的服务器名称sql2kcn-02,并且使用网络库 Named Pipes。别名的设置与使用HOSTS文件有相似之处。& p% z9 v" q5 {2 ^3 ?- L- u
; B/ o4 y7 j: f) p2 Y  u" w
  ( _' e& ~7 b" M
通过以上几个方面的检查,错误 1 发生的原因基本上可以被排除。下面我们再详细描述如何来解决错误 2。1 n3 E: u2 c9 a2 j+ O' Y

4 l! m+ g# G* K+ Q  当用户尝试在查询分析器里面使用sa来连接SQL Server,或者在企业管理器里面使用sa来新建一个SQL Server注册时,经常会遇到如图 2 所示的错误信息。该错误产生的原因是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的登录帐户(如 sa )进行连接。解决方法如下所示:
: m# [$ t( i  [( v( b4 D3 {6 b
' k/ p' V# E9 x1 e0 r  1、 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server;3 T. G2 X8 e/ N) i
% R# E# x6 j, `; Y3 Q
  2、 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡;) k# U! o/ i6 R0 s* y
5 f! k+ p" f# X- Z
  3、 在"身份验证"下,选择"SQL Server和 Windows "。/ K' o: F) }6 I6 }; g7 s& F( D
  p8 q: }* d0 T
  4、 重新启动SQL Server服务。
. B: {4 @* h4 W' w$ K3 m& M( X7 s3 `
  在以上解决方法中,如果在第 1 步中使用"使用 Windows 身份验证"连接 SQL Server 失败,那么我们将遇到一个两难的境地:首先,服务器只允许了 Windows 的身份验证;其次,即使使用了 Windows 身份验证仍然无法连接上服务器。这种情形被形象地称之为"自己把自己锁在了门外",因为无论用何种方式,用户均无法使用进行连接。实际上,我们可以通过修改一个注册表键值来将身份验证方式改为 SQL Server 和 Windows 混合验证,步骤如下所示:
: B: X# p5 v8 A- |7 x) d
" i* a$ c+ ], Q7 x% q. j  1、点击"开始"-"运行",输入regedit,回车进入注册表编辑器;1 L( x/ k& q% q# A" q: m% H7 I2 z
% U2 @$ p: i% ~6 h
  2、依次展开注册表项,浏览到以下注册表键:
- H* H1 _, \( z$ b  W$ H: l! f% ^% w
" [% k* G5 m3 ]4 A+ W[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]
. m3 Y3 c. o0 @, E! [% H3 R. G) q' Y/ s
  3、在屏幕右方找到名称"LoginMode",双击编辑双字节值;
0 k) O7 x% @1 A# ?0 ?& y8 d0 Y2 c6 L. A) j9 Y+ r4 Q4 a
  4、将原值从1改为2,点击"确定";$ w' ]$ I" J" e! [& s! s
5 R3 G: f+ C0 X  S" g
  5、关闭注册表编辑器;7 o7 R& `0 S9 W0 r
6 l' ?) f' R4 [+ Y4 E8 k( A! t
  6、重新启动SQL Server服务。$ L8 ~! Z2 Y: L% O
7 _/ ?& |& C/ m# ^: p$ }
  此时,用户可以成功地使用sa在企业管理器中新建SQL Server注册,但是仍然无法使用Windows身份验证模式来连接SQL Server。这是因为在 SQL Server 中有两个缺省的登录帐户:BUILTIN\Administrators 以及 <机器名>\Administrator 被删除。要恢复这两个帐户,可以使用以下的方法:, t6 {1 a7 J/ ?' m2 z7 z
: X" ~, |  F0 c9 ^. p* \
  1、打开企业管理器,展开服务器组,然后展开服务器;
0 T  X2 ]- x% G, c0 t+ s9 k4 Y: V7 o/ F9 g7 v# p- s" t
  2、展开"安全性",右击"登录",然后单击"新建登录";* S3 Q8 q* y+ l5 C5 v8 e

- G& p( p" ]" ^$ {  3、在"名称"框中,输入 BUILTIN\Administrators;4 z) u* X" ]* y
$ r5 L* A' G6 \! y% \6 f- g/ ~
  4、在"服务器角色"选项卡中,选择"System Administrators" ;
4 \- o5 o' y" H. _* v, V/ b0 ^% d8 }; s9 E0 f
  5、点击"确定"退出;( M" f7 X0 K8 u6 Y* k
, j6 P7 ?4 p0 r( q
  6、使用同样方法添加 <机器名>\Administrator 登录。
5 N1 E! [# S7 ?$ ^; p" ~3 ^
% O6 b: P8 ^, n' f  以下注册表键
" U0 K0 P9 \/ S' m; X* n& p* C. Q+ {( J3 H
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode
3 p8 ^4 s& J" q" K4 r; B5 C" l
' I/ y% y. ^0 r; [  的值决定了SQL Server将采取何种身份验证模式。该值为1,表示使用Windows 身份验证模式;该值为2,表示使用混合模式(Windows 身份验证和 SQL Server 身份验证)。; ~) c% k% a( }9 m. Q- I9 P+ P+ P
( x% {( |+ `* g
  看完如何解决前两个错误的方法之后,让我们来看一下如图 3 所示的第三个错误。
  y  v: _+ a: O( }& q/ ^
" a2 Z" K  s8 F5 m  f  如果遇到第三个错误,一般而言表示客户端已经找到了这台服务器,并且可以进行连接,不过是由于连接的时间大于允许的时间而导致出错。这种情况一般会发生在当用户在Internet上运行企业管理器来注册另外一台同样在Internet上的服务器,并且是慢速连接时,有可能会导致以上的超时错误。有些情况下,由于局域网的网络问题,也会导致这样的错误。
2 L. I& N- h3 P2 R6 k. F2 b0 V2 @( U, ~( L9 F; N8 ]  @
  要解决这样的错误,可以修改客户端的连接超时设置。默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是 4 秒,而查询分析器是 15 秒(这也是为什么在企业管理器里发生错误的可能性比较大的原因)。具体步骤为:1 X1 v4 V; n3 E! u4 _! d$ L
: P# F& u* a5 v" M$ v
  1、在企业管理器中,选择菜单上的"工具",再选择"选项";! d" A/ B/ l/ C

0 P& U$ {$ X) o  2、在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡;" D; J+ x% {1 ?4 f( P+ Q! {

- C8 |- \. }5 p  3、在"连接设置"下的"登录超时(秒)"右边的框中输入一个比较大的数字,如 20。
# A! Q, p9 \) {. ]( p7 @3 h
: u  D" |: {$ o- H8 Z" k/ b9 G0 N  查询分析器中也可以在同样位置进行设置。 <>
+ O! S* d4 P- L3 A) D4 G二、应用程序连接失败* d* E6 u9 r! q
* `8 D- `2 w" g
  以上的三种错误信息都是发生在 SQL Server 自带的客户端工具中,在应用程序中我们也会遇到类似的错误信息,例如:
/ r1 T  R4 V7 L
4 [3 V6 f: Q" n% a4 BMicrosoft OLE DB Provider for SQL Server (0x80004005): O0 Z' }5 M+ `& }
[DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found.6 T0 D! P& A( q* i

! v7 H4 k3 a- d2 N0 h6 fMicrosoft OLE DB Provider for SQL Server (0x80004005)
" Y$ h0 F, q1 L( E用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。
3 P0 x& C4 D& W+ c$ B: |* J8 J) K7 t0 S9 l% F8 `8 j: `; y
Microsoft OLE DB Provider for ODBC Drivers 错误 '80004005'.
, F' b" d: [0 D8 t) k$ V[Microsoft][ODBC SQL Server Driver]超时已过期.) l4 M' d7 d2 o/ P2 `

  P5 U5 g) W* ~# f$ V  首先,让我们来详细看以下的示意图来了解一下使用 ODBC 和使用 OLE DB 连接 SQL Server 有什么不同之处。1 L& m5 M% O& S1 U( C, `$ s
! C' x* e% ^/ [, h7 N
   ) a2 F8 ?2 |* [
" ~2 t6 {  n: y5 e! ~5 v
6 L/ h: a5 f. B; y& J
  从上图中,我们可以看出在实际使用中,应用程序创建和使用各种 ADO 对象,ADO 对象框架调用享用的 OLE DB 提供者。为了访问 SQL Server 数据库,OLE DB 提供了两种不同的方法:用于 SQL Server 的 OLE DB 提供者以及用于 ODBC 的 OLE DB 提供者。这两种不同的方法对应于两种不同的连接字符串,标准的连接字符串写法如下所示:7 T! {' n: E! L8 P

! y8 K% a* S8 h( F5 m  1、使用用于 SQL Server 的 OLE DB 提供者:9 P7 ?0 e7 a4 [" |1 ~
8 T% O- P- B4 _' j) G
  使用 SQL Server 身份验证:
7 h+ v: v7 O& w$ o3 K& N4 |$ ]1 \
oConn.Open "rovider=sqloledb;" &amp; _
- C" B) ?  `* J3 S5 B"Data Source=myServerName;" &amp; _& K/ q) L% J# o3 c
"Initial Catalog=myDatabaseName;" &amp; _7 R% Z% P6 x1 r& X
"User Id=myUsername;" &amp; _
! H" ]+ d6 Q% \"assword=myPassword"5 v' J( K$ _0 A

% N# K6 e$ i1 [4 J; s5 G  使用 Windows 身份验证(信任连接):( f6 j4 |4 G) `

3 s0 J; G0 a/ T4 koConn.Open "rovider=sqloledb;" &amp; _$ ?8 Y% b7 |! Y; P4 N
"Data Source=myServerName;" &amp; _4 b* C1 S$ c* N
"Initial Catalog=myDatabaseName;" &amp; _6 `% y+ O0 A& L; y5 {- G' w! @
"Integrated Security=SSPI"8 R0 l# A4 Z2 _% Q' _

% {$ q7 J; _; k- P& `  2、使用用于 ODBC 的 OLE DB 提供者(不使用 ODBC 数据源):
( h  n9 v: v/ M8 D- S  }: A4 @6 D/ A$ u. P3 n
  使用 SQL Server 身份验证:" q* q9 R; C6 b  B) I9 `& ^

2 w9 J- j3 w3 i. o* w8 G" OoConn.Open "Driver={SQL Server};" &amp; _
2 @5 {; ~4 {/ i+ a3 s3 H1 u"Server=MyServerName;" &amp; _
1 Z7 D- ]+ q% _1 R: R, b"Database=myDatabaseName;" &amp; _' z7 P( ~& o, Q9 V+ G, l: f
"Uid=myUsername;" &amp; _
8 J$ Z2 L* d: K, k3 f"wd=myPassword"7 R# E$ g! o% o& i6 [7 H

1 [$ V: e, R/ T2 B6 c  使用 Windows 身份验证(信任连接):
$ W% J1 K* H) p3 n" E3 l
# E* t3 g8 P2 z! X$ {oConn.Open "Driver={SQL Server};" &amp; _ * m7 c& i0 k/ f2 Q, w
"Server=MyServerName;" &amp; _
' k) }! i1 m- {, r# g7 z"Database=myDatabaseName;" &amp; _
; _) E" z  z* X1 Y' ]"Trusted_Connection=yes"
- U% t( T0 ?/ u, `4 I* U4 q+ D# t* i" w# f  C
  3、使用用于 ODBC 的 OLE DB 提供者(使用 ODBC 数据源):
. s) U* |  x+ }  [$ r+ ]& Y# |, \$ `9 k3 x. }& t
oConn.Open "DSN=mySystemDSN;" &amp; _ 4 V( t* {' u  G$ w7 F
"Uid=myUsername;" &amp; _
) d' @0 d( R/ Z* a5 d2 Z# U. i"wd=myPassword"! e. e1 s; D8 f; _* c
2 h9 @* a4 z9 `/ \
  如果遇到连接失败的情况,我们只要按照一中所示的方法,结合程序中的连接字符串进行检查,基本都能得到解决。另外,还有以下几个要注意的地方:! Q! v  `2 s# x3 {- e  |( ~$ i

& ^- g  U) q, U* v  1、配置 ODBC 数据源时,点击"客户端"配置选项可以让我们指定连接使用的网络库、端口号等属性,如下图所示:
% I: k" _; z: r
- i1 H7 g- B+ p3 S  
% q8 H% V9 `7 M( p3 K* r& W, X0 O
8 a9 C; d2 Z8 n8 m  N7 L4 F2 o/ V4 S% e( P  d
) J4 ~' d( q8 j3 a9 ~: w5 ]
  2、如果遇到连接超时的错误,我们可以在程序中修改 Connection 对象的超时设置,再打开该连接。例如:
0 z4 ?! p/ m& L( E  S4 {" B+ n8 w
</P><>&lt;%* a( e- m9 B1 Q( D, ~8 o/ q
Set Conn = Server.CreateObject("ADODB.Connection")& {9 j( j# k/ p* a1 e5 N2 f0 X* j+ N
DSNtest="DRIVER={SQL Server};SERVER=ServerName;UID=USERWD=password;DATABASE=mydatabase"7 O  z8 H+ B& Y
Conn. Properties("Connect Timeout") = 15 '以秒为单位9 m/ [9 m; W, W+ h8 j& I8 t
Conn.open DSNtest0 t  f/ y, B5 `2 R: ]. \& i8 ]4 d
%&gt;</P><>% s8 c& E! ~' j- t' ]
  3、如果遇到查询超时的错误,我们可以在程序中修改 Recordset 对象的超时设置,再打开结果集。例如:% j' Z3 Z, `. ~1 n
1 t1 q( h% R' K# ?$ w* `
</P><>Dim cn As New ADODB.Connection  S* m, B4 X# s9 l) A
Dim rs As ADODB.Recordset
' a( J. g& U$ W0 |: G$ u1 A' V. . .
& h! K* K4 g- l6 A  |cmd1 = txtQuery.Text
# W7 N! T& c' }Set rs = New ADODB.Recordset0 [2 K8 q% w$ C, ~! w7 f# }; E! l% b
rs.Properties("Command Time Out") = 3009 [3 U; i. m  W( j9 y
'同样以秒为单位,如果设置为 0 表示无限制
$ }3 g  A! c1 y0 o/ V9 Hrs.Open cmd1, cn0 O: Y4 t' h+ L- O
rs.MoveFirst
4 C- F2 F9 F3 [* h  X' a9 ^. . . </P><>
2 G; I; c' c, Q2 p, g  <B>三、小结</B>
1 p0 i- D( E0 _0 q; p
2 n) T% I" Q2 z" G+ E7 U# V  本文针对大部分用户在使用 SQL Server 过程中常见的连接失败的错误,重点讨论了在使用 SQL Server 客户端工具以及用户开发的应用程序两种情况下,如何诊断并解决连接失败的错误。看过本文以后,相信每一个读者都会对 SQL Server 的连接工作原理、身份验证方式以及应用程序开发等有一个较为全面而深入的连接。本文中所有的测试或者示例均在 Windows 2000 Advanced Server + SQL Server 2000 企业版上通过。</P>




欢迎光临 数学建模社区-数学中国 (http://www.madio.net/) Powered by Discuz! X2.5