- 在线时间
- 0 小时
- 最后登录
- 2007-9-23
- 注册时间
- 2004-9-10
- 听众数
- 3
- 收听数
- 0
- 能力
- 0 分
- 体力
- 9975 点
- 威望
- 7 点
- 阅读权限
- 150
- 积分
- 4048
- 相册
- 0
- 日志
- 0
- 记录
- 0
- 帖子
- 1893
- 主题
- 823
- 精华
- 2
- 分享
- 0
- 好友
- 0

我的地盘我做主
该用户从未签到
|
单击"别名"选项卡,还可以为服务器配置别名。服务器的别名是用来连接的名称,连接参数中的服务器是真正的服务器名称,两者可以相同或不同。如下图中,我们可以使用myserver来代替真正的服务器名称sql2kcn-02,并且使用网络库 Named Pipes。别名的设置与使用HOSTS文件有相似之处。0 W C9 e$ f7 C. {+ ^" [
/ a ~5 t- R8 y( R) x. s; \
, V1 M1 U; C1 j4 t通过以上几个方面的检查,错误 1 发生的原因基本上可以被排除。下面我们再详细描述如何来解决错误 2。
) z7 _3 O' L7 L" b; b" Y* W3 h! F3 G I# y+ s0 g
当用户尝试在查询分析器里面使用sa来连接SQL Server,或者在企业管理器里面使用sa来新建一个SQL Server注册时,经常会遇到如图 2 所示的错误信息。该错误产生的原因是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的登录帐户(如 sa )进行连接。解决方法如下所示:
( _$ y0 a2 F4 {+ h% }( c: v! Y
+ Y' q5 A& D5 p5 k* n4 w+ [( @ 1、 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server;- j+ z( ~, n! \" W
, x& X( H1 N! e: H
2、 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡;
3 K2 P8 \3 y& L% [2 n
9 I+ m! t& B8 Q# B3 x) n0 g. S* S 3、 在"身份验证"下,选择"SQL Server和 Windows "。6 F/ m1 W. Z% e8 r' K3 J
; a( M. W+ v. f 4、 重新启动SQL Server服务。" K d5 o+ O# Z/ e5 ^
+ x8 m; t7 u9 ^: {( ]0 C6 E) N 在以上解决方法中,如果在第 1 步中使用"使用 Windows 身份验证"连接 SQL Server 失败,那么我们将遇到一个两难的境地:首先,服务器只允许了 Windows 的身份验证;其次,即使使用了 Windows 身份验证仍然无法连接上服务器。这种情形被形象地称之为"自己把自己锁在了门外",因为无论用何种方式,用户均无法使用进行连接。实际上,我们可以通过修改一个注册表键值来将身份验证方式改为 SQL Server 和 Windows 混合验证,步骤如下所示:
/ y; [& M$ u$ x6 H l
; Y& r) m& p" G! y/ b. j e 1、点击"开始"-"运行",输入regedit,回车进入注册表编辑器;# f% x2 v3 K3 b" M d) A3 N/ F2 r
( W" t/ J4 ~) k% S. |) N# x& h& e 2、依次展开注册表项,浏览到以下注册表键:# [' |; V0 H' d: h0 r
9 |7 J' C1 m+ ~[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]
& f+ ~1 N# X+ m( _
( }* p* R3 O$ ]. Q8 @. u- `4 n8 t' q/ g 3、在屏幕右方找到名称"LoginMode",双击编辑双字节值;+ {( x8 h( I* }, e
8 z2 d9 G9 R, w& J 4、将原值从1改为2,点击"确定";+ W" g4 B. J# D( |3 v
o. D. x/ Z2 ^$ m3 _' W# v
5、关闭注册表编辑器;
! j0 ?$ H- o' P. M6 N! r, G6 Y6 e
7 J. i" T" C4 ?' p4 l" k7 T 6、重新启动SQL Server服务。
2 D* R) N: I. a; w8 y% K7 k- t+ T1 A1 V: W6 l8 q5 T
此时,用户可以成功地使用sa在企业管理器中新建SQL Server注册,但是仍然无法使用Windows身份验证模式来连接SQL Server。这是因为在 SQL Server 中有两个缺省的登录帐户:BUILTIN\Administrators 以及 <机器名>\Administrator 被删除。要恢复这两个帐户,可以使用以下的方法:
$ L; M% y9 Q3 ^; X, S8 B' K; a6 V
0 D$ x0 U) F, u: K( n) I' m) @ 1、打开企业管理器,展开服务器组,然后展开服务器;( @& d, m; h& x$ B
" [( x4 M% n V( W3 p3 R; [
2、展开"安全性",右击"登录",然后单击"新建登录";
: N% ] I2 ?0 N0 N% A2 M4 K3 A; C7 P+ S5 o+ D) f3 M7 V# p4 W
3、在"名称"框中,输入 BUILTIN\Administrators;$ h2 d5 c; y1 N, m& H1 c. Q
4 R1 E4 V# @; J
4、在"服务器角色"选项卡中,选择"System Administrators" ;
* L& A$ }2 u- a+ W c# U
; v# n5 y- G! E2 P2 ~; R9 ]" ~ 5、点击"确定"退出;3 j. ^: c! c- w+ R5 d. L
) y$ {! R3 p, @, q
6、使用同样方法添加 <机器名>\Administrator 登录。
! v4 b" @8 x9 x$ W% g2 ^0 R9 C9 @" k& u$ z$ V
以下注册表键
1 Z: E: ?* ~& j4 x
' n$ x' `; T; ^; B O7 ?HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode" L+ c2 R. |3 L5 v
% o7 r) T3 [; ?; j4 c4 K+ m& k 的值决定了SQL Server将采取何种身份验证模式。该值为1,表示使用Windows 身份验证模式;该值为2,表示使用混合模式(Windows 身份验证和 SQL Server 身份验证)。- h! O& q6 n/ d+ s
. T( M7 D0 h: B( t3 f3 K
看完如何解决前两个错误的方法之后,让我们来看一下如图 3 所示的第三个错误。! | J4 X5 a4 u: d
0 H$ L" P8 y# J) }7 s4 b: U4 } 如果遇到第三个错误,一般而言表示客户端已经找到了这台服务器,并且可以进行连接,不过是由于连接的时间大于允许的时间而导致出错。这种情况一般会发生在当用户在Internet上运行企业管理器来注册另外一台同样在Internet上的服务器,并且是慢速连接时,有可能会导致以上的超时错误。有些情况下,由于局域网的网络问题,也会导致这样的错误。% R1 b0 f$ F) q b" y# P# L
( Z/ i' V+ ~1 w9 {' w 要解决这样的错误,可以修改客户端的连接超时设置。默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是 4 秒,而查询分析器是 15 秒(这也是为什么在企业管理器里发生错误的可能性比较大的原因)。具体步骤为:
5 L9 F0 p* b) _$ ^* r/ m% {; N) B- j" j
1、在企业管理器中,选择菜单上的"工具",再选择"选项";
* w5 }) L3 _; r& Q
% b( [- Y7 L3 l% s9 m8 N3 K# T 2、在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡;
5 N* l3 t% w9 ]6 m; p7 @
2 w3 A8 T1 Z8 z% N) M. o8 v' N 3、在"连接设置"下的"登录超时(秒)"右边的框中输入一个比较大的数字,如 20。
, w: x# u/ b' [, [, @
$ R1 k& G3 |9 A) m3 p* a 查询分析器中也可以在同样位置进行设置。 < >9 \' z2 r. ~, o2 c
二、应用程序连接失败
; o m. w" z, Y/ _3 p4 w( U5 Z, X* B! ]4 I5 z1 _" n
以上的三种错误信息都是发生在 SQL Server 自带的客户端工具中,在应用程序中我们也会遇到类似的错误信息,例如:
3 s+ X- ~9 u2 }' V0 B+ j) e4 ^5 b! u7 D3 n& t* G; H
Microsoft OLE DB Provider for SQL Server (0x80004005)
: \1 K% F# b- d& y[DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found.8 w W) q* b7 O
* Q; k8 I2 E8 ^7 b% E# V% U
Microsoft OLE DB Provider for SQL Server (0x80004005)
0 U6 @5 E- `$ \用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。: Z( j6 G c4 R% N5 T* F6 q- [
$ O) a; _6 m2 f
Microsoft OLE DB Provider for ODBC Drivers 错误 '80004005'.
* `9 ^5 g7 l. o[Microsoft][ODBC SQL Server Driver]超时已过期.% f) i' E5 L- `& G( l5 I
2 w" F' H8 P1 w7 j 首先,让我们来详细看以下的示意图来了解一下使用 ODBC 和使用 OLE DB 连接 SQL Server 有什么不同之处。! y$ F4 [/ p6 |2 |" a6 M" y5 F4 h) g
7 Q8 t: Q; V3 F; e, U6 o; s6 H/ T7 Q6 f$ b
6 P1 w' L+ o- F J" l4 n5 ~
, _! c0 i$ L& ^( ]% A* l
$ ~6 b' X* V X% d7 @ 从上图中,我们可以看出在实际使用中,应用程序创建和使用各种 ADO 对象,ADO 对象框架调用享用的 OLE DB 提供者。为了访问 SQL Server 数据库,OLE DB 提供了两种不同的方法:用于 SQL Server 的 OLE DB 提供者以及用于 ODBC 的 OLE DB 提供者。这两种不同的方法对应于两种不同的连接字符串,标准的连接字符串写法如下所示:8 G; V7 [$ n/ Q
; S, L) i$ ^4 M; c8 N
1、使用用于 SQL Server 的 OLE DB 提供者:2 k5 K; i/ K; t, v4 g1 B C. K
, Y- `/ z. o* E$ ~# B9 n- K+ m 使用 SQL Server 身份验证:
& _: I2 \7 s! Z( a6 m) i8 W+ C3 z, n
) N! r1 M' Q% @ Y" R+ M5 xoConn.Open " rovider=sqloledb;" & _
) }$ n' I2 U, d" I( G, H"Data Source=myServerName;" & _
. c4 E2 r5 @' s7 S8 s8 l"Initial Catalog=myDatabaseName;" & _& u. H8 W# ?3 a
"User Id=myUsername;" & _+ `, r- M& w4 D( \" f0 b
" assword=myPassword"3 y6 D& ~- [& R$ o
( o+ j0 g# [& {$ o( Q
使用 Windows 身份验证(信任连接):
2 x0 ^* r. l0 i& P" J( q6 f
* x- P0 L0 _& s3 f1 i/ F4 joConn.Open " rovider=sqloledb;" & _
. }+ u; d% {/ O y" N"Data Source=myServerName;" & _
3 \3 F/ F1 ~) A& |/ x"Initial Catalog=myDatabaseName;" & _: S% T8 y t( U/ c! a) `! @, ]8 o
"Integrated Security=SSPI"
% |( b& x; Y `* P7 e8 s! c, o9 m- l' ^1 @. B8 j7 ?* V
2、使用用于 ODBC 的 OLE DB 提供者(不使用 ODBC 数据源):
3 H7 R( d s; ~9 ~! [2 o' w% p
+ ^5 e1 D+ L1 Y" e% t5 \% w0 w 使用 SQL Server 身份验证:
. n" P, @3 \4 }; M' o0 h/ a( O; C, E8 g7 y9 H6 l. r% q
oConn.Open "Driver={SQL Server};" & _ $ p5 p: l* d) H: N5 c7 a0 ^
"Server=MyServerName;" & _
; n& _& H1 Y, x"Database=myDatabaseName;" & _9 i/ l" R; `8 ?. u
"Uid=myUsername;" & _
2 D! |3 v. l1 \+ p$ J) }" wd=myPassword"
' n( p& @$ h% T- {7 U$ t! t# D7 |5 l) U
使用 Windows 身份验证(信任连接):
7 w' z t; c4 P! _' c+ x# `: P5 W7 b
oConn.Open "Driver={SQL Server};" & _
0 A7 t! e9 ^$ _+ H( |8 ~"Server=MyServerName;" & _
! x& I! X7 k; _6 s& V"Database=myDatabaseName;" & _! C! g0 f v8 H X7 a0 Y' y
"Trusted_Connection=yes"
. E( m1 H: a: T2 ~0 \* f) _
# D* v4 D3 s! o- K) A$ e4 l3 \ 3、使用用于 ODBC 的 OLE DB 提供者(使用 ODBC 数据源):/ S. ?2 A0 E" ^; T/ w5 c+ M; u
1 \* ?0 b, a w; G2 ]" O6 }oConn.Open "DSN=mySystemDSN;" & _ 6 C9 ]7 `3 v. ^: O. k( x
"Uid=myUsername;" & _
2 l6 T/ d' K5 T" P% f4 M* f8 k" wd=myPassword"
- b x4 F( g4 J/ s5 d. F5 K& h* [) J) L8 ?- ^/ q
如果遇到连接失败的情况,我们只要按照一中所示的方法,结合程序中的连接字符串进行检查,基本都能得到解决。另外,还有以下几个要注意的地方:
, k. Q( d" O" T' h" [4 L) E' W+ h8 v
1、配置 ODBC 数据源时,点击"客户端"配置选项可以让我们指定连接使用的网络库、端口号等属性,如下图所示:" O$ L& Q# i+ H# d; s
$ P+ W( s F* f
: E. K9 n; z9 D, H6 R6 G* {
, w3 q- d* M" w7 A0 C: |( S a3 P, i3 M/ K( C
. t* M' T Q7 R/ r 2、如果遇到连接超时的错误,我们可以在程序中修改 Connection 对象的超时设置,再打开该连接。例如:
4 L3 P, n2 p: k- a: w& j J5 c; a, E
</P>< ><%) B& O9 U1 y9 T+ ^( q p+ G; `3 p
Set Conn = Server.CreateObject("ADODB.Connection")+ D* y4 s, j# p6 i5 C- |
DSNtest="DRIVER={SQL Server};SERVER=ServerName;UID=USER WD=password;DATABASE=mydatabase"
+ T9 g# O4 ?; G3 k, Y0 ^3 f9 N! `Conn. Properties("Connect Timeout") = 15 '以秒为单位
9 ?6 S ]& O k3 d9 S% {Conn.open DSNtest1 q& K- e6 ~1 X9 T) ?* h
%></P>< >! ^/ d" z) S# v e
3、如果遇到查询超时的错误,我们可以在程序中修改 Recordset 对象的超时设置,再打开结果集。例如:$ x. t" k: x' f8 {. E
, {6 F* h [! l# V/ A' v
</P>< >Dim cn As New ADODB.Connection
4 Z; g) L" d8 }* mDim rs As ADODB.Recordset
4 W' Z9 |6 k- W2 T, L% \. . . 5 u9 h& {, V7 J$ p8 Q& j
cmd1 = txtQuery.Text
- D" V8 x- n; ASet rs = New ADODB.Recordset
/ |( U: ?/ u$ J- Krs.Properties("Command Time Out") = 300
1 |6 M) w- b X3 j'同样以秒为单位,如果设置为 0 表示无限制& @- `3 D0 [! T' @2 F4 u# `
rs.Open cmd1, cn3 O/ r T% r* n0 P0 f' }; ?
rs.MoveFirst6 O+ B0 m' H0 g
. . . </P>< >6 n e2 Q* o. X1 U1 Z! d* i
<B>三、小结</B>$ Q% \0 _& I8 ?8 Z- j" i
) Z) x K& m4 y; w
本文针对大部分用户在使用 SQL Server 过程中常见的连接失败的错误,重点讨论了在使用 SQL Server 客户端工具以及用户开发的应用程序两种情况下,如何诊断并解决连接失败的错误。看过本文以后,相信每一个读者都会对 SQL Server 的连接工作原理、身份验证方式以及应用程序开发等有一个较为全面而深入的连接。本文中所有的测试或者示例均在 Windows 2000 Advanced Server + SQL Server 2000 企业版上通过。</P> |
|