QQ登录

只需要一步,快速开始

 注册地址  找回密码
查看: 5219|回复: 1
打印 上一主题 下一主题

SQL Server连接失败错误及解决

[复制链接]
字体大小: 正常 放大
韩冰        

823

主题

3

听众

4048

积分

我的地盘我做主

该用户从未签到

发帖功臣 元老勋章

跳转到指定楼层
1#
发表于 2004-11-19 10:28 |只看该作者 |倒序浏览
|招呼Ta 关注Ta
在使用 SQL Server 的过程中,用户遇到的最多的问题莫过于连接失败了。一般而言,有以下两种连接 SQL Server 的方式,一是利用 SQL Server 自带的客户端工具,如企业管理器、查询分析器、事务探查器等;二是利用用户自己开发的客户端程序,如ASP 脚本、VB程序等,客户端程序中又是利用 ODBC 或者 OLE DB 等连接 SQL Server。下面,我们将就这两种连接方式,具体谈谈如何来解决连接失败的问题。' N$ l& E* T4 ]: ~8 E1 a7 M

) Q6 b" v3 j) S  一、客户端工具连接失败& d  J1 r1 z- n$ ^& F

! t( ?* G9 C7 k( @+ z- b3 D  在使用 SQL Server 自带的客户端工具(以企业管理器为例)连接 SQL Server时,最常见的错误有如下一些:" G6 v2 h* m) b; f

3 @4 c1 D% p: l5 y- o. K% L  1、SQL Server 不存在或访问被拒绝
" T0 k' F9 V2 {* k* I/ S  i
: `- t& s! R, ^' N; l- H8 ]# b    ConnectionOpen (Connect())
$ ~. a* z2 l, T: C' `- f1 c  C' W/ {9 F0 t: u
  ; I3 b. _/ P% p/ ]8 H+ e0 ]
  d3 X3 a7 ~  U% @
5 D0 O, o( s. l2 G8 ?5 d
1 I* w" ~0 f6 I' \, U2 w6 R2 ~

% ]' C1 n/ P# l; R; D$ V/ }  2、用户'sa'登录失败。原因:未与信任 SQL Server 连接相关联。, _+ d! V6 K. g$ [
5 e# _- E7 Z6 C' |
  
. G* u- X' P0 @( m( A' M7 {* K. T7 ]2 D: ^& P# _& z

, b  A$ h, b5 D- r" L
* V" P! K0 s9 B; b$ D8 D+ G  U; [
# r/ U  v8 B. G! b3 Y  3、超时已过期。
) E( d' r6 w2 x) P
1 I' A/ {  ~( C/ _1 e  
! O5 X, O5 w, ?" i$ E9 p+ T" W3 X( N) |3 o6 {& f5 @
( a5 t" @; m- D8 {% O
下面我们依次介绍如何来解决这三个最常见的连接错误。6 C. T$ J5 F( [: j. r$ y

0 O: L* X* \  ~- R9 W6 G  第一个错误"SQL Server 不存在或访问被拒绝"通常是最复杂的,错误发生的原因比较多,需要检查的方面也比较多。一般说来,有以下几种可能性:! D! z1 @$ F2 c4 |  d0 r, ~8 E6 R' m+ E

- b8 A; h6 i$ s  _( ?5 w  1、SQL Server名称或IP地址拼写有误;7 W, U7 O+ M' x- C3 o# @
) B* j% {/ @) _0 Q- _$ m
  2、服务器端网络配置有误;
* s5 v2 T: Y9 m( |- V$ E1 ?8 E: r  B/ ~- f& G0 _
  3、客户端网络配置有误。9 N4 K3 y% y  Z" z; C- i  H( C

0 g9 A# X, V( z0 C# G1 @# J  要解决这个问题,我们一般要遵循以下的步骤来一步步找出导致错误的原因。
7 _/ i" Q$ F! o# o% l5 _
5 W- M+ i6 d0 @4 z$ u( N% s( d  首先,检查网络物理连接:
  F( ]' }9 T: w
& s3 I3 T! H$ E; j   ping <服务器IP地址> + b5 `% |0 ]6 `4 E1 ?% ^% ]
 9 V! {/ ^( W0 S& Q& x
  或者
4 B# W3 `/ F7 [7 v8 I+ z7 ?1 i! ]  @; K, k
   ping <服务器名称>, D  e2 H! o+ j$ y' [% K) d" A

. R4 [5 }% t1 G  }. h  如果 ping <服务器IP地址> 失败,说明物理连接有问题,这时候要检查硬件设备,如网卡、HUB、路由器等。还有一种可能是由于客户端和服务器之间安装有防火墙软件造成的,比如 ISA Server。防火墙软件可能会屏蔽对 ping、telnet 等的响应,因此在检查连接问题的时候,我们要先把防火墙软件暂时关闭,或者打开所有被封闭的端口。
! A! P/ Y# [5 R+ U) v
- F6 Q( v& T6 a2 B, y5 d  如果ping <服务器IP地址> 成功而 ping <服务器名称> 失败,则说明名字解析有问题,这时候要检查 DNS 服务是否正常。有时候客户端和服务器不在同一个局域网里面,这时候很可能无法直接使用服务器名称来标识该服务器,这时候我们可以使用HOSTS文件来进行名字解析,具体的方法是:
( K, _) A' [8 P, }2 d& |4 S7 `" L# t7 T/ P' m5 E: J; D3 u
  1、使用记事本打开HOSTS文件(一般情况下位于C:\WINNT\system32\drivers\etc).8 S2 M$ |9 K. s, x
; H/ O) W9 ]/ d! L. T
  2、添加一条IP地址与服务器名称的对应记录,如:% j) X9 d% M9 B" o: k

8 o% M8 h0 q2 f3 Z3 h    172.168.10.24 myserver
8 a. x6 @3 P; _. `. c  _8 H
$ d1 i. F- B# v1 U  d  也可以在 SQL Server 的客户端网络实用工具里面进行配置,后面会有详细说明。6 U1 F# t: h$ G8 U2 I+ s6 S2 L/ {

0 Q5 H2 u, Z* p1 Q5 k# C  其次,使用 telnet 命令检查SQL Server服务器工作状态:
' z1 f, c3 W, D: \7 M+ T( _4 M: `0 ~- }7 m
   telnet <服务器IP地址> 14336 G/ I2 V9 y( @3 L3 Q2 y

" x. ]5 {% K1 e( j  如果命令执行成功,可以看到屏幕一闪之后光标在左上角不停闪动,这说明 SQL Server 服务器工作正常,并且正在监听1433端口的 TCP/IP 连接;如果命令返回"无法打开连接"的错误信息,则说明服务器端没有启动 SQL Server 服务,也可能服务器端没启用 TCP/IP 协议,或者服务器端没有在 SQL Server 默认的端口1433上监听。: `  A& O" ]1 U
6 O, ~$ p+ A0 A* T, j- Q
  接着,我们要到服务器上检查服务器端的网络配置,检查是否启用了命名管道,是否启用了 TCP/IP 协议等等。我们可以利用 SQL Server 自带的服务器网络使用工具来进行检查。* ~) U) p, a  p; m+ x  C) w
) N4 b. |& h  k, p3 r8 j8 r
  点击:程序 -> Microsoft SQL Server -> 服务器网络使用工具,打开该工具后看到的画面如下图所示:1 [" ?* n' j3 `! i$ \- _: S
0 j3 Y( g7 \4 s  \' O$ @+ |# a
  ( s" s! ~7 {2 ^4 N

0 a! S6 U6 Q/ {' m0 d7 p
. \7 I# W9 J' T& f, @) g/ x9 T1 |7 Y  从这里我们可以看到服务器启用了哪些协议。一般而言,我们启用命名管道以及 TCP/IP 协议。0 m' T9 J' [5 O- i- r3 y

1 I: K( _0 V# ?  点中 TCP/IP 协议,选择"属性",我们可以来检查 SQK Server 服务默认端口的设置,如下图所示:
0 J- x7 B: s$ r9 O! H9 j
: ^# u* s/ r! j) o& k+ D  
$ o. w/ W7 m' ~0 Y  Y( a1 s# h; B' J/ H. ?; q! f9 r
5 I4 P- F# ]6 _) ]6 @- {4 |
+ @! c+ }" {  h5 W6 X, `+ T
. j* @% e, i2 w
  一般而言,我们使用 SQL Server 默认的1433端口。如果选中"隐藏服务器",则意味着客户端无法通过枚举服务器来看到这台服务器,起到了保护的作用,但不影响连接。- t1 I# x" i3 X* ]" w
" U* C; A: H+ g$ Q3 P1 a; a' I3 T
  检查完了服务器端的网络配置,接下来我们要到客户端检查客户端的网络配置。我们同样可以利用 SQL Server 自带的客户端网络使用工具来进行检查,所不同的是这次是在客户端来运行这个工具。
/ J2 B* T1 b+ q# `4 ?
7 ?* p. L: Y" h% z# m' \. ?  点击:程序 -> Microsoft SQL Server -> 客户端网络使用工具, 打开该工具后看到的画面如下图所示:. J2 O" ^) b2 \$ A

8 |& ^$ Z4 R5 E" D  
2 }$ ~0 f% ~+ s. C
8 I" v$ O9 M" }2 H8 j. N. i( e2 b. T  L# D2 `- y- o" S# }
  从这里我们可以看到客户端启用了哪些协议。一般而言,我们同样需要启用命名管道以及 TCP/IP 协议。" `' s% B$ B; P2 D3 q$ ^
! H5 i8 N7 h* z& I
  点击 TCP/IP 协议,选择"属性",可以检查客户端默认连接端口的设置,如下图所示。' q7 ~7 L8 _: m" R+ F  p" o0 K

1 ]0 T! R  g9 R- k+ r9 _$ T  
# g2 k, V! U4 D0 s2 ]9 u6 X) ?$ ^) G/ i4 }  F4 s
& I  X4 ?9 a/ x9 C3 C3 R
  该端口必须与服务器一致。
zan
转播转播0 分享淘帖0 分享分享0 收藏收藏0 支持支持0 反对反对0 微信微信
韩冰        

823

主题

3

听众

4048

积分

我的地盘我做主

该用户从未签到

发帖功臣 元老勋章

单击"别名"选项卡,还可以为服务器配置别名。服务器的别名是用来连接的名称,连接参数中的服务器是真正的服务器名称,两者可以相同或不同。如下图中,我们可以使用myserver来代替真正的服务器名称sql2kcn-02,并且使用网络库 Named Pipes。别名的设置与使用HOSTS文件有相似之处。# q. A( S4 O. X- V

5 }5 ^! U! O$ ?  0 x3 C8 B, j  [) c
通过以上几个方面的检查,错误 1 发生的原因基本上可以被排除。下面我们再详细描述如何来解决错误 2。" K0 X% c: }0 U
. a/ K- E1 n) D# M0 N2 J/ _0 ^
  当用户尝试在查询分析器里面使用sa来连接SQL Server,或者在企业管理器里面使用sa来新建一个SQL Server注册时,经常会遇到如图 2 所示的错误信息。该错误产生的原因是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的登录帐户(如 sa )进行连接。解决方法如下所示:
1 [' a. s# @6 \
; [" q. H/ d. j$ f* i) i! d  1、 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server;% j) |, s6 A$ ^4 K& X: I; v! z

. t5 m" t: p( m' D7 k1 Y7 z0 @  2、 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡;& D. [7 E' o2 r1 M6 h5 o

. `1 d' |- P0 u; c5 N# H7 L* B6 z  3、 在"身份验证"下,选择"SQL Server和 Windows "。
' j8 ?) h4 ^  O9 L% A
# ]% D- X: i/ q0 u  4、 重新启动SQL Server服务。) {% y( q# \9 H' R: A% c

5 y/ L" G; O; A0 i( p  在以上解决方法中,如果在第 1 步中使用"使用 Windows 身份验证"连接 SQL Server 失败,那么我们将遇到一个两难的境地:首先,服务器只允许了 Windows 的身份验证;其次,即使使用了 Windows 身份验证仍然无法连接上服务器。这种情形被形象地称之为"自己把自己锁在了门外",因为无论用何种方式,用户均无法使用进行连接。实际上,我们可以通过修改一个注册表键值来将身份验证方式改为 SQL Server 和 Windows 混合验证,步骤如下所示:6 q6 H6 \5 u* G: g
3 {! E  x1 m) K* t) O
  1、点击"开始"-"运行",输入regedit,回车进入注册表编辑器;
4 ~! h$ H1 ^" V; N5 Y2 Z. m1 D- W6 @2 c- K$ a! q$ ]# t
  2、依次展开注册表项,浏览到以下注册表键:. \% @1 x( Q2 u

5 T4 [  O7 K% Y4 }$ D[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]) n: i. z1 \; L% h: m$ B; J9 p
8 l9 W8 A) D& O% F/ {
  3、在屏幕右方找到名称"LoginMode",双击编辑双字节值;" C" K* H# U  d+ Q& j% f7 W
  l$ F* c- t9 B/ |0 N# N" I
  4、将原值从1改为2,点击"确定";
; c8 S7 N( p6 S* y2 Q* H( _
, u/ ?8 E) Y$ o+ Z7 `/ N  5、关闭注册表编辑器;
6 v- Y2 ~" X1 k4 A. F, K5 R) q6 S2 _+ Z) y5 r; m7 F
  6、重新启动SQL Server服务。
2 R0 ^/ X/ f' x3 h- g2 C, o
7 A: a7 s6 q9 z9 r4 H7 O  此时,用户可以成功地使用sa在企业管理器中新建SQL Server注册,但是仍然无法使用Windows身份验证模式来连接SQL Server。这是因为在 SQL Server 中有两个缺省的登录帐户:BUILTIN\Administrators 以及 <机器名>\Administrator 被删除。要恢复这两个帐户,可以使用以下的方法:7 a! ?6 Q& ^2 F' x( w
& k- V: \( S$ P- |4 K
  1、打开企业管理器,展开服务器组,然后展开服务器;2 b! O" [' M3 T" O2 @. L$ E+ {
0 \6 ?; q/ T( R/ i7 y7 c
  2、展开"安全性",右击"登录",然后单击"新建登录";3 M/ N& y" K$ l6 W( r

( X+ e; ?; ?( ]0 T7 H  3、在"名称"框中,输入 BUILTIN\Administrators;/ }* W- \; E  f; f
' @9 d+ p& c7 C
  4、在"服务器角色"选项卡中,选择"System Administrators" ;
  y4 T+ x  x; s1 }0 P$ x
1 U. i: p) M5 }7 V" Y  5、点击"确定"退出;! s, _4 Y$ q5 q

$ D) h; `9 R- N  6、使用同样方法添加 <机器名>\Administrator 登录。* E3 j7 b  E& Q! J5 t
; _. Y! {  K  b+ R; d7 ?4 H# r
  以下注册表键3 l# k& }+ s) C4 r
' g& p! C! T' |9 f" ^- U# l. g2 U
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode# q6 q$ L" I  C# H2 o

0 `+ i8 W+ p6 A/ `& v  的值决定了SQL Server将采取何种身份验证模式。该值为1,表示使用Windows 身份验证模式;该值为2,表示使用混合模式(Windows 身份验证和 SQL Server 身份验证)。
9 Y7 }7 b. _1 L2 P# L' ]+ S7 g$ E/ }$ P
  看完如何解决前两个错误的方法之后,让我们来看一下如图 3 所示的第三个错误。
% p, a/ I7 P; _5 T) F; i' z
; r1 u; T- T! n/ ]: W6 Z" ?& a: C  如果遇到第三个错误,一般而言表示客户端已经找到了这台服务器,并且可以进行连接,不过是由于连接的时间大于允许的时间而导致出错。这种情况一般会发生在当用户在Internet上运行企业管理器来注册另外一台同样在Internet上的服务器,并且是慢速连接时,有可能会导致以上的超时错误。有些情况下,由于局域网的网络问题,也会导致这样的错误。; K9 l6 A5 O$ T8 o) ~" W& M
* v& R7 s3 |% ]3 h1 _
  要解决这样的错误,可以修改客户端的连接超时设置。默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是 4 秒,而查询分析器是 15 秒(这也是为什么在企业管理器里发生错误的可能性比较大的原因)。具体步骤为:+ `" _- F6 G6 n. x
6 X8 {! a5 ~- E) {; H) v8 K1 T
  1、在企业管理器中,选择菜单上的"工具",再选择"选项";2 e+ B5 i% N2 y1 T  P. S6 H& V* t

" a+ v) U" n: v  2、在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡;
. k3 h0 P# B+ ~0 ]: ]4 o1 o
" I# C) v6 w2 g9 B/ L8 c  3、在"连接设置"下的"登录超时(秒)"右边的框中输入一个比较大的数字,如 20。
- d& F% @5 D: c- n& }
6 N+ p0 U  K$ h) V+ H2 h  查询分析器中也可以在同样位置进行设置。 <>
" g  Y2 {& d( c# z: K二、应用程序连接失败
/ Z6 Q' e; a$ r5 m
) a2 T, }: d3 [- d, E6 x  以上的三种错误信息都是发生在 SQL Server 自带的客户端工具中,在应用程序中我们也会遇到类似的错误信息,例如:
1 o2 Y7 N" \: [7 K  u$ Z) \; a4 a& d7 N! R; |3 r
Microsoft OLE DB Provider for SQL Server (0x80004005)1 w0 r+ g3 F: j8 I5 G5 S
[DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found.
" F6 u1 Q/ w0 C1 m9 H1 J3 Z1 n% R; k8 g. b  {( r* [2 j
Microsoft OLE DB Provider for SQL Server (0x80004005): t4 I5 |9 U/ j% y: L/ ~8 ^, J1 H4 I
用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。& v+ s5 e+ p' ?' F9 B

1 Z! D: I: M! F1 s4 B) ?$ G9 EMicrosoft OLE DB Provider for ODBC Drivers 错误 '80004005'.
2 S/ d; a1 Y4 o, g- s' Y[Microsoft][ODBC SQL Server Driver]超时已过期.
& v7 I" _/ h  X5 P; K) {8 }1 i. r0 z3 a
  首先,让我们来详细看以下的示意图来了解一下使用 ODBC 和使用 OLE DB 连接 SQL Server 有什么不同之处。/ W* [( A, W: @9 j! I/ x
5 l/ e  P. R  e/ ~! i5 ?' {
   ' J; q$ R  P( B/ ^; {- t
0 {4 |7 @/ P2 E# }* c: ]' {1 h

% M9 i* l, q1 @  从上图中,我们可以看出在实际使用中,应用程序创建和使用各种 ADO 对象,ADO 对象框架调用享用的 OLE DB 提供者。为了访问 SQL Server 数据库,OLE DB 提供了两种不同的方法:用于 SQL Server 的 OLE DB 提供者以及用于 ODBC 的 OLE DB 提供者。这两种不同的方法对应于两种不同的连接字符串,标准的连接字符串写法如下所示:( p! n) S  d- J$ M/ G! N8 v" L

6 j1 Q9 b) I& L1 }  1、使用用于 SQL Server 的 OLE DB 提供者:: z/ r" [5 K" m. U# B7 V  v; \
, J- I  o4 h% Q- a" e1 \1 A
  使用 SQL Server 身份验证:) G6 `+ H) [# u0 d. S

* r! b5 I1 F. }7 x/ {oConn.Open "rovider=sqloledb;" &amp; _ 1 E* @2 j: @& j% @' L1 Y
"Data Source=myServerName;" &amp; _
9 K- @# N/ f! x$ H) O5 p"Initial Catalog=myDatabaseName;" &amp; _
, H: z  E7 t$ e5 ["User Id=myUsername;" &amp; _
) }* U8 K6 f* l$ F"assword=myPassword"
4 K0 Z, `5 b# J' B: n- R1 U
3 L; |' R, l& I7 R" ]. G7 b9 x  使用 Windows 身份验证(信任连接):3 @1 I% j, Y' H) ?9 e

* J$ W( z) r* a2 `8 }: |oConn.Open "rovider=sqloledb;" &amp; _
$ u4 o' V" p2 h% R0 z"Data Source=myServerName;" &amp; _
: t- i# b+ M" Y/ n9 ^3 C  v"Initial Catalog=myDatabaseName;" &amp; _
- L- ^1 R  u. b5 |5 Y# P"Integrated Security=SSPI"
% N2 J! p/ i  v1 `- a* q- T/ B  j6 a! u! b% U9 [2 t
  2、使用用于 ODBC 的 OLE DB 提供者(不使用 ODBC 数据源):
& y% c2 y" e! Z* c) ~
6 O6 l5 v" i* ^/ U# }  使用 SQL Server 身份验证:, _6 ^2 K- O& R( L# ~
: x3 Y" V; F2 i* N
oConn.Open "Driver={SQL Server};" &amp; _
! i- @* |- F% `! `( b) \"Server=MyServerName;" &amp; _
% d* H/ E: Y1 K# I3 h2 l0 V"Database=myDatabaseName;" &amp; _
2 H' s  @. Z( t6 s! Y"Uid=myUsername;" &amp; _% Q7 s2 g) p7 a( I- o' v8 F( h
"wd=myPassword"5 \3 X% B% E. `$ g, ~

# a3 A  K( z. l6 |  使用 Windows 身份验证(信任连接):
1 r2 R# I6 C+ H) M5 f" F6 n  _: I
) K6 q# g$ O; p1 ?oConn.Open "Driver={SQL Server};" &amp; _ ( I6 C) S; f% ~. T
"Server=MyServerName;" &amp; _% ~! B3 \% P! F
"Database=myDatabaseName;" &amp; _5 I3 a# R% W# H) H4 Z7 c* c
"Trusted_Connection=yes"6 T' L. J3 d4 d3 |" t  `

( Y# c6 [( d* X, b7 f  3、使用用于 ODBC 的 OLE DB 提供者(使用 ODBC 数据源):
) p/ e( w/ W& U* B
$ v3 F7 P' K# n0 voConn.Open "DSN=mySystemDSN;" &amp; _ 5 }# m8 ]7 `2 ?2 `3 y
"Uid=myUsername;" &amp; _
5 ~) _) _. U9 h"wd=myPassword"
2 k% d4 F* j; S9 s
: Y  f+ W& E$ T( N: B  如果遇到连接失败的情况,我们只要按照一中所示的方法,结合程序中的连接字符串进行检查,基本都能得到解决。另外,还有以下几个要注意的地方:
2 e+ y: B  S5 {
3 d9 v! S3 S9 W5 }  1、配置 ODBC 数据源时,点击"客户端"配置选项可以让我们指定连接使用的网络库、端口号等属性,如下图所示:0 P' M, o& W) h& U

. ]* Z( f' b. u0 D( v+ |; V- |   4 X8 A+ {9 s: }! V' ?; P* |$ x3 `
! d, W; i% A2 i8 G) m6 h/ v
$ n8 c( i+ v3 O% c- U) r
' l) H4 [" o0 ^
  2、如果遇到连接超时的错误,我们可以在程序中修改 Connection 对象的超时设置,再打开该连接。例如: 8 f+ V' G" c( H0 b1 [

  C" Q' u) z9 s( d% s1 u# b</P><>&lt;%
9 t' h  ?9 Z& U8 Y* D5 ?& N* hSet Conn = Server.CreateObject("ADODB.Connection"), G1 d) F/ g* M, ?1 [
DSNtest="DRIVER={SQL Server};SERVER=ServerName;UID=USERWD=password;DATABASE=mydatabase"
; ?1 G( x8 {' K; ?3 r- n, M, TConn. Properties("Connect Timeout") = 15 '以秒为单位
9 D) p# G! r7 G+ }Conn.open DSNtest# S% R0 g1 W0 V) f9 \/ S
%&gt;</P><>
" b2 B  F' P' @, o  3、如果遇到查询超时的错误,我们可以在程序中修改 Recordset 对象的超时设置,再打开结果集。例如:, x. \( _, N% Z1 @/ R. G5 {

# G4 @# d# o3 V" y4 ~' W  V</P><>Dim cn As New ADODB.Connection" r# f; V' v7 x
Dim rs As ADODB.Recordset
1 D8 ]; K4 ?* e7 h% O; i' l3 C. . . 2 p8 s6 }! {# }1 F/ _& _/ \; @2 b  v# f
cmd1 = txtQuery.Text
9 n: l4 E* O' _& C; i+ Q6 O  tSet rs = New ADODB.Recordset9 \. k- R3 c) Y. ]0 f
rs.Properties("Command Time Out") = 300
. E0 e2 [- i8 p6 C: y'同样以秒为单位,如果设置为 0 表示无限制
. Q) ?- z" _  g+ Z. ?+ ors.Open cmd1, cn) |5 Y2 q- V& n2 O* F/ v9 ]. U
rs.MoveFirst/ }' j5 ^& F( h$ T7 {
. . . </P><>
/ d" x- P4 s6 M. P/ ~  <B>三、小结</B>7 `9 |8 k) i. i3 {* K
- y/ l* ^8 \% C8 l8 X' N4 A! B+ [
  本文针对大部分用户在使用 SQL Server 过程中常见的连接失败的错误,重点讨论了在使用 SQL Server 客户端工具以及用户开发的应用程序两种情况下,如何诊断并解决连接失败的错误。看过本文以后,相信每一个读者都会对 SQL Server 的连接工作原理、身份验证方式以及应用程序开发等有一个较为全面而深入的连接。本文中所有的测试或者示例均在 Windows 2000 Advanced Server + SQL Server 2000 企业版上通过。</P>
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册地址

qq
收缩
  • 电话咨询

  • 04714969085
fastpost

关于我们| 联系我们| 诚征英才| 对外合作| 产品服务| QQ

手机版|Archiver| |繁體中文 手机客户端  

蒙公网安备 15010502000194号

Powered by Discuz! X2.5   © 2001-2013 数学建模网-数学中国 ( 蒙ICP备14002410号-3 蒙BBS备-0002号 )     论坛法律顾问:王兆丰

GMT+8, 2026-10-9 04:57 , Processed in 0.351804 second(s), 57 queries .

回顶部