- 在线时间
- 0 小时
- 最后登录
- 2007-9-23
- 注册时间
- 2004-9-10
- 听众数
- 3
- 收听数
- 0
- 能力
- 0 分
- 体力
- 9975 点
- 威望
- 7 点
- 阅读权限
- 150
- 积分
- 4048
- 相册
- 0
- 日志
- 0
- 记录
- 0
- 帖子
- 1893
- 主题
- 823
- 精华
- 2
- 分享
- 0
- 好友
- 0

我的地盘我做主
该用户从未签到
|
单击"别名"选项卡,还可以为服务器配置别名。服务器的别名是用来连接的名称,连接参数中的服务器是真正的服务器名称,两者可以相同或不同。如下图中,我们可以使用myserver来代替真正的服务器名称sql2kcn-02,并且使用网络库 Named Pipes。别名的设置与使用HOSTS文件有相似之处。# q. A( S4 O. X- V
5 }5 ^! U! O$ ? 0 x3 C8 B, j [) c
通过以上几个方面的检查,错误 1 发生的原因基本上可以被排除。下面我们再详细描述如何来解决错误 2。" K0 X% c: }0 U
. a/ K- E1 n) D# M0 N2 J/ _0 ^
当用户尝试在查询分析器里面使用sa来连接SQL Server,或者在企业管理器里面使用sa来新建一个SQL Server注册时,经常会遇到如图 2 所示的错误信息。该错误产生的原因是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的登录帐户(如 sa )进行连接。解决方法如下所示:
1 [' a. s# @6 \
; [" q. H/ d. j$ f* i) i! d 1、 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server;% j) |, s6 A$ ^4 K& X: I; v! z
. t5 m" t: p( m' D7 k1 Y7 z0 @ 2、 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡;& D. [7 E' o2 r1 M6 h5 o
. `1 d' |- P0 u; c5 N# H7 L* B6 z 3、 在"身份验证"下,选择"SQL Server和 Windows "。
' j8 ?) h4 ^ O9 L% A
# ]% D- X: i/ q0 u 4、 重新启动SQL Server服务。) {% y( q# \9 H' R: A% c
5 y/ L" G; O; A0 i( p 在以上解决方法中,如果在第 1 步中使用"使用 Windows 身份验证"连接 SQL Server 失败,那么我们将遇到一个两难的境地:首先,服务器只允许了 Windows 的身份验证;其次,即使使用了 Windows 身份验证仍然无法连接上服务器。这种情形被形象地称之为"自己把自己锁在了门外",因为无论用何种方式,用户均无法使用进行连接。实际上,我们可以通过修改一个注册表键值来将身份验证方式改为 SQL Server 和 Windows 混合验证,步骤如下所示:6 q6 H6 \5 u* G: g
3 {! E x1 m) K* t) O
1、点击"开始"-"运行",输入regedit,回车进入注册表编辑器;
4 ~! h$ H1 ^" V; N5 Y2 Z. m1 D- W6 @2 c- K$ a! q$ ]# t
2、依次展开注册表项,浏览到以下注册表键:. \% @1 x( Q2 u
5 T4 [ O7 K% Y4 }$ D[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]) n: i. z1 \; L% h: m$ B; J9 p
8 l9 W8 A) D& O% F/ {
3、在屏幕右方找到名称"LoginMode",双击编辑双字节值;" C" K* H# U d+ Q& j% f7 W
l$ F* c- t9 B/ |0 N# N" I
4、将原值从1改为2,点击"确定";
; c8 S7 N( p6 S* y2 Q* H( _
, u/ ?8 E) Y$ o+ Z7 `/ N 5、关闭注册表编辑器;
6 v- Y2 ~" X1 k4 A. F, K5 R) q6 S2 _+ Z) y5 r; m7 F
6、重新启动SQL Server服务。
2 R0 ^/ X/ f' x3 h- g2 C, o
7 A: a7 s6 q9 z9 r4 H7 O 此时,用户可以成功地使用sa在企业管理器中新建SQL Server注册,但是仍然无法使用Windows身份验证模式来连接SQL Server。这是因为在 SQL Server 中有两个缺省的登录帐户:BUILTIN\Administrators 以及 <机器名>\Administrator 被删除。要恢复这两个帐户,可以使用以下的方法:7 a! ?6 Q& ^2 F' x( w
& k- V: \( S$ P- |4 K
1、打开企业管理器,展开服务器组,然后展开服务器;2 b! O" [' M3 T" O2 @. L$ E+ {
0 \6 ?; q/ T( R/ i7 y7 c
2、展开"安全性",右击"登录",然后单击"新建登录";3 M/ N& y" K$ l6 W( r
( X+ e; ?; ?( ]0 T7 H 3、在"名称"框中,输入 BUILTIN\Administrators;/ }* W- \; E f; f
' @9 d+ p& c7 C
4、在"服务器角色"选项卡中,选择"System Administrators" ;
y4 T+ x x; s1 }0 P$ x
1 U. i: p) M5 }7 V" Y 5、点击"确定"退出;! s, _4 Y$ q5 q
$ D) h; `9 R- N 6、使用同样方法添加 <机器名>\Administrator 登录。* E3 j7 b E& Q! J5 t
; _. Y! { K b+ R; d7 ?4 H# r
以下注册表键3 l# k& }+ s) C4 r
' g& p! C! T' |9 f" ^- U# l. g2 U
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode# q6 q$ L" I C# H2 o
0 `+ i8 W+ p6 A/ `& v 的值决定了SQL Server将采取何种身份验证模式。该值为1,表示使用Windows 身份验证模式;该值为2,表示使用混合模式(Windows 身份验证和 SQL Server 身份验证)。
9 Y7 }7 b. _1 L2 P# L' ]+ S7 g$ E/ }$ P
看完如何解决前两个错误的方法之后,让我们来看一下如图 3 所示的第三个错误。
% p, a/ I7 P; _5 T) F; i' z
; r1 u; T- T! n/ ]: W6 Z" ?& a: C 如果遇到第三个错误,一般而言表示客户端已经找到了这台服务器,并且可以进行连接,不过是由于连接的时间大于允许的时间而导致出错。这种情况一般会发生在当用户在Internet上运行企业管理器来注册另外一台同样在Internet上的服务器,并且是慢速连接时,有可能会导致以上的超时错误。有些情况下,由于局域网的网络问题,也会导致这样的错误。; K9 l6 A5 O$ T8 o) ~" W& M
* v& R7 s3 |% ]3 h1 _
要解决这样的错误,可以修改客户端的连接超时设置。默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是 4 秒,而查询分析器是 15 秒(这也是为什么在企业管理器里发生错误的可能性比较大的原因)。具体步骤为:+ `" _- F6 G6 n. x
6 X8 {! a5 ~- E) {; H) v8 K1 T
1、在企业管理器中,选择菜单上的"工具",再选择"选项";2 e+ B5 i% N2 y1 T P. S6 H& V* t
" a+ v) U" n: v 2、在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡;
. k3 h0 P# B+ ~0 ]: ]4 o1 o
" I# C) v6 w2 g9 B/ L8 c 3、在"连接设置"下的"登录超时(秒)"右边的框中输入一个比较大的数字,如 20。
- d& F% @5 D: c- n& }
6 N+ p0 U K$ h) V+ H2 h 查询分析器中也可以在同样位置进行设置。 < >
" g Y2 {& d( c# z: K二、应用程序连接失败
/ Z6 Q' e; a$ r5 m
) a2 T, }: d3 [- d, E6 x 以上的三种错误信息都是发生在 SQL Server 自带的客户端工具中,在应用程序中我们也会遇到类似的错误信息,例如:
1 o2 Y7 N" \: [7 K u$ Z) \; a4 a& d7 N! R; |3 r
Microsoft OLE DB Provider for SQL Server (0x80004005)1 w0 r+ g3 F: j8 I5 G5 S
[DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found.
" F6 u1 Q/ w0 C1 m9 H1 J3 Z1 n% R; k8 g. b {( r* [2 j
Microsoft OLE DB Provider for SQL Server (0x80004005): t4 I5 |9 U/ j% y: L/ ~8 ^, J1 H4 I
用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。& v+ s5 e+ p' ?' F9 B
1 Z! D: I: M! F1 s4 B) ?$ G9 EMicrosoft OLE DB Provider for ODBC Drivers 错误 '80004005'.
2 S/ d; a1 Y4 o, g- s' Y[Microsoft][ODBC SQL Server Driver]超时已过期.
& v7 I" _/ h X5 P; K) {8 }1 i. r0 z3 a
首先,让我们来详细看以下的示意图来了解一下使用 ODBC 和使用 OLE DB 连接 SQL Server 有什么不同之处。/ W* [( A, W: @9 j! I/ x
5 l/ e P. R e/ ~! i5 ?' {
' J; q$ R P( B/ ^; {- t
0 {4 |7 @/ P2 E# }* c: ]' {1 h
% M9 i* l, q1 @ 从上图中,我们可以看出在实际使用中,应用程序创建和使用各种 ADO 对象,ADO 对象框架调用享用的 OLE DB 提供者。为了访问 SQL Server 数据库,OLE DB 提供了两种不同的方法:用于 SQL Server 的 OLE DB 提供者以及用于 ODBC 的 OLE DB 提供者。这两种不同的方法对应于两种不同的连接字符串,标准的连接字符串写法如下所示:( p! n) S d- J$ M/ G! N8 v" L
6 j1 Q9 b) I& L1 } 1、使用用于 SQL Server 的 OLE DB 提供者:: z/ r" [5 K" m. U# B7 V v; \
, J- I o4 h% Q- a" e1 \1 A
使用 SQL Server 身份验证:) G6 `+ H) [# u0 d. S
* r! b5 I1 F. }7 x/ {oConn.Open " rovider=sqloledb;" & _ 1 E* @2 j: @& j% @' L1 Y
"Data Source=myServerName;" & _
9 K- @# N/ f! x$ H) O5 p"Initial Catalog=myDatabaseName;" & _
, H: z E7 t$ e5 ["User Id=myUsername;" & _
) }* U8 K6 f* l$ F" assword=myPassword"
4 K0 Z, `5 b# J' B: n- R1 U
3 L; |' R, l& I7 R" ]. G7 b9 x 使用 Windows 身份验证(信任连接):3 @1 I% j, Y' H) ?9 e
* J$ W( z) r* a2 `8 }: |oConn.Open " rovider=sqloledb;" & _
$ u4 o' V" p2 h% R0 z"Data Source=myServerName;" & _
: t- i# b+ M" Y/ n9 ^3 C v"Initial Catalog=myDatabaseName;" & _
- L- ^1 R u. b5 |5 Y# P"Integrated Security=SSPI"
% N2 J! p/ i v1 `- a* q- T/ B j6 a! u! b% U9 [2 t
2、使用用于 ODBC 的 OLE DB 提供者(不使用 ODBC 数据源):
& y% c2 y" e! Z* c) ~
6 O6 l5 v" i* ^/ U# } 使用 SQL Server 身份验证:, _6 ^2 K- O& R( L# ~
: x3 Y" V; F2 i* N
oConn.Open "Driver={SQL Server};" & _
! i- @* |- F% `! `( b) \"Server=MyServerName;" & _
% d* H/ E: Y1 K# I3 h2 l0 V"Database=myDatabaseName;" & _
2 H' s @. Z( t6 s! Y"Uid=myUsername;" & _% Q7 s2 g) p7 a( I- o' v8 F( h
" wd=myPassword"5 \3 X% B% E. `$ g, ~
# a3 A K( z. l6 | 使用 Windows 身份验证(信任连接):
1 r2 R# I6 C+ H) M5 f" F6 n _: I
) K6 q# g$ O; p1 ?oConn.Open "Driver={SQL Server};" & _ ( I6 C) S; f% ~. T
"Server=MyServerName;" & _% ~! B3 \% P! F
"Database=myDatabaseName;" & _5 I3 a# R% W# H) H4 Z7 c* c
"Trusted_Connection=yes"6 T' L. J3 d4 d3 |" t `
( Y# c6 [( d* X, b7 f 3、使用用于 ODBC 的 OLE DB 提供者(使用 ODBC 数据源):
) p/ e( w/ W& U* B
$ v3 F7 P' K# n0 voConn.Open "DSN=mySystemDSN;" & _ 5 }# m8 ]7 `2 ?2 `3 y
"Uid=myUsername;" & _
5 ~) _) _. U9 h" wd=myPassword"
2 k% d4 F* j; S9 s
: Y f+ W& E$ T( N: B 如果遇到连接失败的情况,我们只要按照一中所示的方法,结合程序中的连接字符串进行检查,基本都能得到解决。另外,还有以下几个要注意的地方:
2 e+ y: B S5 {
3 d9 v! S3 S9 W5 } 1、配置 ODBC 数据源时,点击"客户端"配置选项可以让我们指定连接使用的网络库、端口号等属性,如下图所示:0 P' M, o& W) h& U
. ]* Z( f' b. u0 D( v+ |; V- | 4 X8 A+ {9 s: }! V' ?; P* |$ x3 `
! d, W; i% A2 i8 G) m6 h/ v
$ n8 c( i+ v3 O% c- U) r
' l) H4 [" o0 ^
2、如果遇到连接超时的错误,我们可以在程序中修改 Connection 对象的超时设置,再打开该连接。例如: 8 f+ V' G" c( H0 b1 [
C" Q' u) z9 s( d% s1 u# b</P>< ><%
9 t' h ?9 Z& U8 Y* D5 ?& N* hSet Conn = Server.CreateObject("ADODB.Connection"), G1 d) F/ g* M, ?1 [
DSNtest="DRIVER={SQL Server};SERVER=ServerName;UID=USER WD=password;DATABASE=mydatabase"
; ?1 G( x8 {' K; ?3 r- n, M, TConn. Properties("Connect Timeout") = 15 '以秒为单位
9 D) p# G! r7 G+ }Conn.open DSNtest# S% R0 g1 W0 V) f9 \/ S
%></P>< >
" b2 B F' P' @, o 3、如果遇到查询超时的错误,我们可以在程序中修改 Recordset 对象的超时设置,再打开结果集。例如:, x. \( _, N% Z1 @/ R. G5 {
# G4 @# d# o3 V" y4 ~' W V</P>< >Dim cn As New ADODB.Connection" r# f; V' v7 x
Dim rs As ADODB.Recordset
1 D8 ]; K4 ?* e7 h% O; i' l3 C. . . 2 p8 s6 }! {# }1 F/ _& _/ \; @2 b v# f
cmd1 = txtQuery.Text
9 n: l4 E* O' _& C; i+ Q6 O tSet rs = New ADODB.Recordset9 \. k- R3 c) Y. ]0 f
rs.Properties("Command Time Out") = 300
. E0 e2 [- i8 p6 C: y'同样以秒为单位,如果设置为 0 表示无限制
. Q) ?- z" _ g+ Z. ?+ ors.Open cmd1, cn) |5 Y2 q- V& n2 O* F/ v9 ]. U
rs.MoveFirst/ }' j5 ^& F( h$ T7 {
. . . </P>< >
/ d" x- P4 s6 M. P/ ~ <B>三、小结</B>7 `9 |8 k) i. i3 {* K
- y/ l* ^8 \% C8 l8 X' N4 A! B+ [
本文针对大部分用户在使用 SQL Server 过程中常见的连接失败的错误,重点讨论了在使用 SQL Server 客户端工具以及用户开发的应用程序两种情况下,如何诊断并解决连接失败的错误。看过本文以后,相信每一个读者都会对 SQL Server 的连接工作原理、身份验证方式以及应用程序开发等有一个较为全面而深入的连接。本文中所有的测试或者示例均在 Windows 2000 Advanced Server + SQL Server 2000 企业版上通过。</P> |
|