- 在线时间
- 0 小时
- 最后登录
- 2007-9-23
- 注册时间
- 2004-9-10
- 听众数
- 3
- 收听数
- 0
- 能力
- 0 分
- 体力
- 9975 点
- 威望
- 7 点
- 阅读权限
- 150
- 积分
- 4048
- 相册
- 0
- 日志
- 0
- 记录
- 0
- 帖子
- 1893
- 主题
- 823
- 精华
- 2
- 分享
- 0
- 好友
- 0

我的地盘我做主
该用户从未签到
|
单击"别名"选项卡,还可以为服务器配置别名。服务器的别名是用来连接的名称,连接参数中的服务器是真正的服务器名称,两者可以相同或不同。如下图中,我们可以使用myserver来代替真正的服务器名称sql2kcn-02,并且使用网络库 Named Pipes。别名的设置与使用HOSTS文件有相似之处。
9 R: h4 z) z0 v8 A# ]
c1 K; j) p q+ X' } : A2 O/ k! i* _; X s* E
通过以上几个方面的检查,错误 1 发生的原因基本上可以被排除。下面我们再详细描述如何来解决错误 2。# \7 d4 @ J9 V& d6 {
" Q& s8 w" H: e$ p; @
当用户尝试在查询分析器里面使用sa来连接SQL Server,或者在企业管理器里面使用sa来新建一个SQL Server注册时,经常会遇到如图 2 所示的错误信息。该错误产生的原因是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的登录帐户(如 sa )进行连接。解决方法如下所示:: R7 v7 g; G6 J0 v$ D- n, h0 Q
8 H5 q0 K7 x4 `6 [. u8 b/ g 1、 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server;' J% Q* J% H; f b* b# M# V
' y0 `1 Z* {* g- m/ o- r 2、 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡;
( `5 G; \6 k! I% O' M3 z9 p# M
( {( L0 q, d) }! t8 w 3、 在"身份验证"下,选择"SQL Server和 Windows "。
# s' L9 E y& y
$ {5 K, b: k: ^7 @$ H% _& V 4、 重新启动SQL Server服务。
2 @0 R- e" O1 D0 z
4 ?2 j) d7 T0 V- A2 P 在以上解决方法中,如果在第 1 步中使用"使用 Windows 身份验证"连接 SQL Server 失败,那么我们将遇到一个两难的境地:首先,服务器只允许了 Windows 的身份验证;其次,即使使用了 Windows 身份验证仍然无法连接上服务器。这种情形被形象地称之为"自己把自己锁在了门外",因为无论用何种方式,用户均无法使用进行连接。实际上,我们可以通过修改一个注册表键值来将身份验证方式改为 SQL Server 和 Windows 混合验证,步骤如下所示:# |; V9 R$ z8 s& H
6 B4 L+ ?- T7 F% V" B l6 I 1、点击"开始"-"运行",输入regedit,回车进入注册表编辑器;
0 p4 v2 {! j# S4 |% U0 A' q9 |2 V
2、依次展开注册表项,浏览到以下注册表键:
% s! O: F, @/ U; H Y! C8 p& w0 x3 N N' {" U9 c9 D# @. X3 f. |
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]+ u5 o. e5 l. M0 _, `7 e
4 A$ d- \3 [/ S7 k- Q. V
3、在屏幕右方找到名称"LoginMode",双击编辑双字节值;! i- Y9 U8 y, T
# k) c3 i! i5 J. i5 s L8 S2 c
4、将原值从1改为2,点击"确定";
/ ]4 o/ d1 Z/ Q) O& |8 @; ?* x# d) R) M0 F# g& J, ^' I
5、关闭注册表编辑器;. P( o1 B$ {3 k5 v
3 J: d# ]- k8 |* Z$ @ 6、重新启动SQL Server服务。1 J7 e* t c5 D% i/ h$ A- D# R
3 w: l: r; l0 }0 _ H 此时,用户可以成功地使用sa在企业管理器中新建SQL Server注册,但是仍然无法使用Windows身份验证模式来连接SQL Server。这是因为在 SQL Server 中有两个缺省的登录帐户:BUILTIN\Administrators 以及 <机器名>\Administrator 被删除。要恢复这两个帐户,可以使用以下的方法:8 S* m. n, P) T
) d5 k/ z) v; R- T 1、打开企业管理器,展开服务器组,然后展开服务器;
/ i4 O0 f2 I/ ?) ]; u5 g, j
& q. T. b* [( \! m* a. ` u 2、展开"安全性",右击"登录",然后单击"新建登录";
7 u0 C, u* r& G$ O$ G7 N, Q" m" J+ g/ c- R0 c
3、在"名称"框中,输入 BUILTIN\Administrators;
& R$ T# X7 `2 Q% V
6 q. _7 Z( h0 O3 J' r A0 |2 K O 4、在"服务器角色"选项卡中,选择"System Administrators" ;8 U* @1 t2 m7 o/ V/ t- h
. S! P6 \! ~0 d. p1 m U& r
5、点击"确定"退出;7 G1 \6 l, L; o0 A) p& l
G" Y* i: E' l. X* p2 z- A
6、使用同样方法添加 <机器名>\Administrator 登录。# ?# W6 [0 v; K! ~( o6 ^
/ ?3 [8 q. v" F7 Y
以下注册表键
1 f! _# @* `# J' g; Z2 U) X2 S
% w/ p5 g9 E; j* w) S+ ], Y, u) m; r( C5 lHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode7 L# @! A7 R- H6 Y4 R
8 E* s" d3 @. O4 X+ G. I 的值决定了SQL Server将采取何种身份验证模式。该值为1,表示使用Windows 身份验证模式;该值为2,表示使用混合模式(Windows 身份验证和 SQL Server 身份验证)。9 }+ T$ e% n7 ~6 \
0 H. m2 u) g! l. y& e
看完如何解决前两个错误的方法之后,让我们来看一下如图 3 所示的第三个错误。7 n6 Y' H0 J3 d% N
( g8 j' f+ ~8 ]; F# I! A) Q" v
如果遇到第三个错误,一般而言表示客户端已经找到了这台服务器,并且可以进行连接,不过是由于连接的时间大于允许的时间而导致出错。这种情况一般会发生在当用户在Internet上运行企业管理器来注册另外一台同样在Internet上的服务器,并且是慢速连接时,有可能会导致以上的超时错误。有些情况下,由于局域网的网络问题,也会导致这样的错误。9 @( u( y3 ]2 G% ], W8 N5 {* t7 p
3 m9 o O, X8 P9 K, }* h
要解决这样的错误,可以修改客户端的连接超时设置。默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是 4 秒,而查询分析器是 15 秒(这也是为什么在企业管理器里发生错误的可能性比较大的原因)。具体步骤为:) ]: m8 I# s7 B8 ?3 v% C; [* P
& t. ]- R+ p2 q: N9 x; w, Z' c! [5 {! q
1、在企业管理器中,选择菜单上的"工具",再选择"选项";
* J) _3 F" Q R4 J) y
: a( ]0 B3 E4 y6 [3 U( N 2、在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡;
- ]0 b. x. T& R" N3 b+ \; Q% O8 M+ H& @& f4 L
3、在"连接设置"下的"登录超时(秒)"右边的框中输入一个比较大的数字,如 20。
: Z7 K7 Y* R& J% X1 `* z
0 ^) p/ h$ o- y$ h 查询分析器中也可以在同样位置进行设置。 < >
* n& @3 \9 U1 I6 e! u$ A( m5 D* A二、应用程序连接失败
9 V+ W' i( ]& x2 w6 x
/ k4 T: x; V* x% u! I 以上的三种错误信息都是发生在 SQL Server 自带的客户端工具中,在应用程序中我们也会遇到类似的错误信息,例如:
9 q+ o6 D: q* X/ b/ I4 |* C
4 y8 V3 h# t3 b* C+ RMicrosoft OLE DB Provider for SQL Server (0x80004005)8 L7 `, A! L1 B P1 o
[DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found.
8 Z R! B: |! Q1 G# }: P
8 h) N. e8 I- I9 {; h/ dMicrosoft OLE DB Provider for SQL Server (0x80004005)
) |' t6 v+ C. J8 N( [5 ]8 {用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。( p- t9 U1 K4 I& Y9 N
$ e) e/ w, S8 [! J% U1 }
Microsoft OLE DB Provider for ODBC Drivers 错误 '80004005'.
$ Z) g$ \, V/ e1 W! ?8 e[Microsoft][ODBC SQL Server Driver]超时已过期. K% o, d, T* r
7 U- D, I& x2 d3 s
首先,让我们来详细看以下的示意图来了解一下使用 ODBC 和使用 OLE DB 连接 SQL Server 有什么不同之处。
, X4 W# A; B, C7 S% K& k. Q
$ R0 H: l' Q+ t0 H; f3 j! e4 p
% Q( h% ^* ?1 X% @, h" R @
* p3 c+ d1 h* V& v" l9 T% {# B
6 w! Y) f/ @# @2 [4 g 从上图中,我们可以看出在实际使用中,应用程序创建和使用各种 ADO 对象,ADO 对象框架调用享用的 OLE DB 提供者。为了访问 SQL Server 数据库,OLE DB 提供了两种不同的方法:用于 SQL Server 的 OLE DB 提供者以及用于 ODBC 的 OLE DB 提供者。这两种不同的方法对应于两种不同的连接字符串,标准的连接字符串写法如下所示:
# ^) H1 V0 [% ^5 O0 g, }' A9 J/ {7 R4 P& O
1、使用用于 SQL Server 的 OLE DB 提供者:
7 T# t8 @* S/ R0 T) v# H) n. `6 }& c3 S8 W6 ~
使用 SQL Server 身份验证:
8 k+ n8 O1 O- K% P5 e; v5 V7 ^( ^
# h$ _, o2 h! i& ^+ C& BoConn.Open " rovider=sqloledb;" & _
, p8 i/ C6 T. |3 h5 ^0 `$ a"Data Source=myServerName;" & _
4 L3 n6 N, W1 @"Initial Catalog=myDatabaseName;" & _
! o# ]7 E% [. t# u# A% ?/ c"User Id=myUsername;" & _
) B9 P0 V' n. s2 i d" assword=myPassword") b" ^+ D, e X9 ]& ^; a
# d" h2 W" z! I: ^; _; R, y
使用 Windows 身份验证(信任连接):# @: p- Y: ]% m" v" R
8 G6 _: \% N: G( ~oConn.Open " rovider=sqloledb;" & _. [9 o' a+ N# T! D
"Data Source=myServerName;" & _5 U) D2 \ W0 y
"Initial Catalog=myDatabaseName;" & _
0 F {7 e: i7 w$ }9 s"Integrated Security=SSPI"4 b5 o4 b6 F1 |& t; u7 ^; [0 e C4 ]
3 L5 O) G! N' e
2、使用用于 ODBC 的 OLE DB 提供者(不使用 ODBC 数据源):$ Z( y& N! e! y' Y
' M* a8 w( `4 Z( k; j. I
使用 SQL Server 身份验证:, I9 j; A, A/ @
6 a' Y) ?. K3 e7 SoConn.Open "Driver={SQL Server};" & _
6 H. {1 q# n- X3 x"Server=MyServerName;" & _( k3 P% p7 T6 h6 o
"Database=myDatabaseName;" & _
, M* O$ M( D8 D, D& ^- [" L: i"Uid=myUsername;" & _
9 Q8 o S: h! X, r& Q; D$ G" wd=myPassword", a' h* K# w y6 |6 ]4 N' i" ^. `
( b3 g6 ~6 S& h0 j 使用 Windows 身份验证(信任连接):% a& w0 ]* Z( W( }
# Z: `5 J7 E8 woConn.Open "Driver={SQL Server};" & _ ) X$ z& N$ Q& f! w& ~; }. S/ v
"Server=MyServerName;" & _
0 k d& l1 T" C g, W/ w4 K"Database=myDatabaseName;" & _
/ {" i: d0 m H+ ~, H7 u. T0 x+ ?"Trusted_Connection=yes"
* R' d8 Z) L: L! a# b) e
9 a3 w' c0 {5 w, Q 3、使用用于 ODBC 的 OLE DB 提供者(使用 ODBC 数据源):5 P6 P0 x2 ]; S* z. ~* u
, Q2 g8 t4 e2 k* H
oConn.Open "DSN=mySystemDSN;" & _
8 D7 t8 `, S X* p, [* p+ M1 u- ~"Uid=myUsername;" & _ , L$ h* u6 }5 h1 l; e; o
" wd=myPassword"8 k( d9 t- B6 e& G" q
4 {6 N9 |' Q9 H/ h
如果遇到连接失败的情况,我们只要按照一中所示的方法,结合程序中的连接字符串进行检查,基本都能得到解决。另外,还有以下几个要注意的地方:
" |2 `1 Q# C6 z$ ~$ M7 E' V
$ ]' A7 K: \& c 1、配置 ODBC 数据源时,点击"客户端"配置选项可以让我们指定连接使用的网络库、端口号等属性,如下图所示:
; F. {* W5 W* q. T! P6 W1 ?
( I2 g: e( y: b" h2 u' V; F0 Z
. G8 _7 j. ]' `- y
) n8 l& T$ N; G2 ? [/ w. u+ z
8 I5 g& @- ]$ x0 l6 j' t$ d0 k& G5 N8 X
2、如果遇到连接超时的错误,我们可以在程序中修改 Connection 对象的超时设置,再打开该连接。例如:
( t% s4 A$ V& u- m8 U" |( [& V
1 {6 ~0 f. |5 G</P>< ><%
# t, ?0 c7 d4 b( a" z9 fSet Conn = Server.CreateObject("ADODB.Connection")& ?7 W, u# L5 c* j3 c" e
DSNtest="DRIVER={SQL Server};SERVER=ServerName;UID=USER WD=password;DATABASE=mydatabase"
6 E7 r2 K. K7 I* |; B& C A6 h8 }Conn. Properties("Connect Timeout") = 15 '以秒为单位
: N$ V+ a$ N. Q0 d+ [Conn.open DSNtest7 x9 M h9 n+ N1 a% D- L
%></P>< >7 L+ G6 G o" ^$ R! S
3、如果遇到查询超时的错误,我们可以在程序中修改 Recordset 对象的超时设置,再打开结果集。例如:
) r; x1 M$ r5 @$ l. t5 I) B6 m A5 ?
7 W$ m& X+ P3 O* {& A! j) q</P>< >Dim cn As New ADODB.Connection
9 b' U! G4 N, bDim rs As ADODB.Recordset
5 G4 `3 S1 I2 b O# G. . . 4 O! c4 V% _7 I+ ^3 U
cmd1 = txtQuery.Text. F& J p: ^ O8 J* f$ r
Set rs = New ADODB.Recordset" \3 r2 a! y% ^6 F$ ~- N
rs.Properties("Command Time Out") = 300
9 w# b. u5 D& `% I8 x'同样以秒为单位,如果设置为 0 表示无限制
% H* W A2 E: e) L$ ^rs.Open cmd1, cn7 _0 @% z3 _% s S
rs.MoveFirst
* k4 T; W! F$ l" J. . . </P>< >
- c+ e- r: C8 t! O% p <B>三、小结</B>
' J4 m! ` }+ N; A% g) n
- m5 l' o! @. h1 ]2 Q# E3 F 本文针对大部分用户在使用 SQL Server 过程中常见的连接失败的错误,重点讨论了在使用 SQL Server 客户端工具以及用户开发的应用程序两种情况下,如何诊断并解决连接失败的错误。看过本文以后,相信每一个读者都会对 SQL Server 的连接工作原理、身份验证方式以及应用程序开发等有一个较为全面而深入的连接。本文中所有的测试或者示例均在 Windows 2000 Advanced Server + SQL Server 2000 企业版上通过。</P> |
|