QQ登录

只需要一步,快速开始

 注册地址  找回密码
查看: 5222|回复: 1
打印 上一主题 下一主题

SQL Server连接失败错误及解决

[复制链接]
字体大小: 正常 放大
韩冰        

823

主题

3

听众

4048

积分

我的地盘我做主

该用户从未签到

发帖功臣 元老勋章

跳转到指定楼层
1#
发表于 2004-11-19 10:28 |只看该作者 |倒序浏览
|招呼Ta 关注Ta
在使用 SQL Server 的过程中,用户遇到的最多的问题莫过于连接失败了。一般而言,有以下两种连接 SQL Server 的方式,一是利用 SQL Server 自带的客户端工具,如企业管理器、查询分析器、事务探查器等;二是利用用户自己开发的客户端程序,如ASP 脚本、VB程序等,客户端程序中又是利用 ODBC 或者 OLE DB 等连接 SQL Server。下面,我们将就这两种连接方式,具体谈谈如何来解决连接失败的问题。  ^$ }% R, n; W6 ~1 S

  ~; ^# S: G& \4 n6 K& f. L  一、客户端工具连接失败. [7 Y8 `1 C% f; e! @! u

! T$ ^" W0 `. T* J4 h. t9 n  在使用 SQL Server 自带的客户端工具(以企业管理器为例)连接 SQL Server时,最常见的错误有如下一些:$ b! k9 d. p) l& c. P, r
) ~9 S9 j. T$ I
  1、SQL Server 不存在或访问被拒绝
$ b, n2 A5 U" H% w8 t2 z! T7 O6 ]4 z, {! Y. D' ~, k7 @
    ConnectionOpen (Connect())' ]4 p8 f( a  L2 A  {7 u& J' X

4 u) h3 Z! C, ?& j4 Y* P4 l  
  g$ b9 P. g" `0 h8 e5 k. m  p
4 v" Z8 B* S" R2 D  U: Z# }
7 z: N5 K# N1 M9 p& T2 P4 e
. L0 I5 y, M' H  q2 g) N7 B& O+ O( y# S% ]" k, v
  2、用户'sa'登录失败。原因:未与信任 SQL Server 连接相关联。1 Q6 `9 G! V, Q
  o/ \' L* h, S4 m
  + C/ H$ b% x- z- H8 N4 h. H: o# I
( v5 S! A- B! C- b( q, Y/ b

7 ]1 G8 |4 y# A% T: K2 q2 H& ]. D* O, o" r2 c/ a
- _5 I' F  R  D4 C2 Q) c& }
  3、超时已过期。0 r+ g7 i" v2 Z& k) k

- o' s* ?( t: A' z   1 q8 C' S' X7 e2 S

: D& ^; c" H, Y( ~5 U: @# [1 V( ^5 s8 A
下面我们依次介绍如何来解决这三个最常见的连接错误。
4 \  v+ n+ ]- c5 H$ E
( u& _9 I( u; _0 K" z  第一个错误"SQL Server 不存在或访问被拒绝"通常是最复杂的,错误发生的原因比较多,需要检查的方面也比较多。一般说来,有以下几种可能性:
9 V; A  |- k1 d. X
7 s0 X9 \3 \9 Y6 w8 J  1、SQL Server名称或IP地址拼写有误;
/ m/ w3 x8 {  e" T1 s5 \4 \) g! h
/ Y! a/ C  g% B$ v& v5 l. m+ g  2、服务器端网络配置有误;
1 j) I/ V1 a& i1 P2 V' B
/ @( v% B  ]$ b" R' b  3、客户端网络配置有误。
7 z$ m5 S5 Q4 [& x. C
, d6 Q- T& a7 Q8 y6 u  要解决这个问题,我们一般要遵循以下的步骤来一步步找出导致错误的原因。' u& A' I+ w  o! n: j
% h& e, w  m: H) U( F
  首先,检查网络物理连接:
1 [* l* |, h* p) l5 o6 ^' _% O# k7 b( i  h! P
   ping <服务器IP地址> 8 a& t7 |! u. d! H; [
 
0 e7 E# m( m! Z6 z1 g  或者. l/ T& q+ W9 ~3 z
9 {0 [( _# K* L9 N5 N8 ?5 ]2 }
   ping <服务器名称>8 {% t- G# a/ ~  g
( h6 [7 K7 K. B2 ?$ x2 Y7 }
  如果 ping <服务器IP地址> 失败,说明物理连接有问题,这时候要检查硬件设备,如网卡、HUB、路由器等。还有一种可能是由于客户端和服务器之间安装有防火墙软件造成的,比如 ISA Server。防火墙软件可能会屏蔽对 ping、telnet 等的响应,因此在检查连接问题的时候,我们要先把防火墙软件暂时关闭,或者打开所有被封闭的端口。, p) m2 G* e7 P, t
8 U5 @9 m- @$ p" |
  如果ping <服务器IP地址> 成功而 ping <服务器名称> 失败,则说明名字解析有问题,这时候要检查 DNS 服务是否正常。有时候客户端和服务器不在同一个局域网里面,这时候很可能无法直接使用服务器名称来标识该服务器,这时候我们可以使用HOSTS文件来进行名字解析,具体的方法是:
) P" `) G1 m* Q" T
$ O3 {( A6 C- O  1、使用记事本打开HOSTS文件(一般情况下位于C:\WINNT\system32\drivers\etc).- e9 D$ D$ x" {
: q# O8 A7 i4 z
  2、添加一条IP地址与服务器名称的对应记录,如:
6 q" @0 Y( R) k) X+ P" m2 k6 B- \# ~6 b0 r/ P* y+ a; L
    172.168.10.24 myserver5 s7 |1 c3 g& m9 K4 U

  g4 g2 P2 q" Q/ B) w- w5 V  也可以在 SQL Server 的客户端网络实用工具里面进行配置,后面会有详细说明。
/ b* ^8 _/ c# S0 e0 X7 W, U2 P& F# ?$ A  k. X! W
  其次,使用 telnet 命令检查SQL Server服务器工作状态:, `7 C. U( `) U/ [0 g+ |. C

! }/ g* w6 Z! v, h) G' U5 g   telnet <服务器IP地址> 14332 H8 h& ^6 a. l4 H

# N. Z/ g* O$ J: c; Y, S) V  如果命令执行成功,可以看到屏幕一闪之后光标在左上角不停闪动,这说明 SQL Server 服务器工作正常,并且正在监听1433端口的 TCP/IP 连接;如果命令返回"无法打开连接"的错误信息,则说明服务器端没有启动 SQL Server 服务,也可能服务器端没启用 TCP/IP 协议,或者服务器端没有在 SQL Server 默认的端口1433上监听。3 g+ K2 i  |3 ^% x9 Z) L  Q* O. b5 ^

: g  L- A" e' S* t  接着,我们要到服务器上检查服务器端的网络配置,检查是否启用了命名管道,是否启用了 TCP/IP 协议等等。我们可以利用 SQL Server 自带的服务器网络使用工具来进行检查。; X9 x( m  g1 K# N

' V4 J1 ?9 e/ B  点击:程序 -> Microsoft SQL Server -> 服务器网络使用工具,打开该工具后看到的画面如下图所示:* U9 c& M  @1 d3 x8 \

. ]( ], l$ |; p" A4 q( u# A  / K2 ~6 `' H8 o6 q" C
8 u9 t% Q) T9 {

- i9 y6 @/ C2 a- w2 P  从这里我们可以看到服务器启用了哪些协议。一般而言,我们启用命名管道以及 TCP/IP 协议。. e1 }. I% P- f3 |

' N! l* \; h- @# u4 V! l7 \! ?4 f  点中 TCP/IP 协议,选择"属性",我们可以来检查 SQK Server 服务默认端口的设置,如下图所示:
; b! {$ a/ {, t9 K3 X
6 a* A. D; d# D2 E7 |7 O0 U' @) t  
: s' R. C3 v8 D( S4 I( l4 P  L; a8 p+ V* `5 s: x; K; x# z

! }6 P3 d9 |. }8 c  y0 o' ]
5 b! a* D. `! u& T
, k: x9 `# g, s" d0 _/ p  一般而言,我们使用 SQL Server 默认的1433端口。如果选中"隐藏服务器",则意味着客户端无法通过枚举服务器来看到这台服务器,起到了保护的作用,但不影响连接。% I5 I4 ^: ^; e1 |

+ T  ^6 j+ w. `5 W& C1 M" h  检查完了服务器端的网络配置,接下来我们要到客户端检查客户端的网络配置。我们同样可以利用 SQL Server 自带的客户端网络使用工具来进行检查,所不同的是这次是在客户端来运行这个工具。
8 O: u  l1 H8 C: a0 v- y0 \% ^1 W( K
: f9 Z# n. o0 R( m$ d+ F" w) h  点击:程序 -> Microsoft SQL Server -> 客户端网络使用工具, 打开该工具后看到的画面如下图所示:; G% E4 q- V1 }. y' |0 f
4 \# B- W) }6 m% y: N: p9 Q) E- g
  
& c% D, n! W6 t8 @9 z
, ?. ?# ]  |5 K' y6 e/ m6 L, f* v
  从这里我们可以看到客户端启用了哪些协议。一般而言,我们同样需要启用命名管道以及 TCP/IP 协议。
4 @+ K+ z+ O4 d( \1 G' n
# g7 h( t1 W) j  E$ k& w$ p  点击 TCP/IP 协议,选择"属性",可以检查客户端默认连接端口的设置,如下图所示。
  c' p2 G  \* y- q) @3 e: @$ Q0 T4 P; x% }( [
  
" G/ \! K6 }0 T. i, T( a6 t
4 P0 D! {6 C+ j! }$ X1 e# N/ `
/ C8 q" z, S7 \' o0 I) [( r  该端口必须与服务器一致。
zan
转播转播0 分享淘帖0 分享分享0 收藏收藏0 支持支持0 反对反对0 微信微信
韩冰        

823

主题

3

听众

4048

积分

我的地盘我做主

该用户从未签到

发帖功臣 元老勋章

单击"别名"选项卡,还可以为服务器配置别名。服务器的别名是用来连接的名称,连接参数中的服务器是真正的服务器名称,两者可以相同或不同。如下图中,我们可以使用myserver来代替真正的服务器名称sql2kcn-02,并且使用网络库 Named Pipes。别名的设置与使用HOSTS文件有相似之处。
9 R: h4 z) z0 v8 A# ]
  c1 K; j) p  q+ X' }  : A2 O/ k! i* _; X  s* E
通过以上几个方面的检查,错误 1 发生的原因基本上可以被排除。下面我们再详细描述如何来解决错误 2。# \7 d4 @  J9 V& d6 {
" Q& s8 w" H: e$ p; @
  当用户尝试在查询分析器里面使用sa来连接SQL Server,或者在企业管理器里面使用sa来新建一个SQL Server注册时,经常会遇到如图 2 所示的错误信息。该错误产生的原因是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的登录帐户(如 sa )进行连接。解决方法如下所示:: R7 v7 g; G6 J0 v$ D- n, h0 Q

8 H5 q0 K7 x4 `6 [. u8 b/ g  1、 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server;' J% Q* J% H; f  b* b# M# V

' y0 `1 Z* {* g- m/ o- r  2、 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡;
( `5 G; \6 k! I% O' M3 z9 p# M
( {( L0 q, d) }! t8 w  3、 在"身份验证"下,选择"SQL Server和 Windows "。
# s' L9 E  y& y
$ {5 K, b: k: ^7 @$ H% _& V  4、 重新启动SQL Server服务。
2 @0 R- e" O1 D0 z
4 ?2 j) d7 T0 V- A2 P  在以上解决方法中,如果在第 1 步中使用"使用 Windows 身份验证"连接 SQL Server 失败,那么我们将遇到一个两难的境地:首先,服务器只允许了 Windows 的身份验证;其次,即使使用了 Windows 身份验证仍然无法连接上服务器。这种情形被形象地称之为"自己把自己锁在了门外",因为无论用何种方式,用户均无法使用进行连接。实际上,我们可以通过修改一个注册表键值来将身份验证方式改为 SQL Server 和 Windows 混合验证,步骤如下所示:# |; V9 R$ z8 s& H

6 B4 L+ ?- T7 F% V" B  l6 I  1、点击"开始"-"运行",输入regedit,回车进入注册表编辑器;
0 p4 v2 {! j# S4 |% U0 A' q9 |2 V
  2、依次展开注册表项,浏览到以下注册表键:
% s! O: F, @/ U; H  Y! C8 p& w0 x3 N  N' {" U9 c9 D# @. X3 f. |
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]+ u5 o. e5 l. M0 _, `7 e
4 A$ d- \3 [/ S7 k- Q. V
  3、在屏幕右方找到名称"LoginMode",双击编辑双字节值;! i- Y9 U8 y, T
# k) c3 i! i5 J. i5 s  L8 S2 c
  4、将原值从1改为2,点击"确定";
/ ]4 o/ d1 Z/ Q) O& |8 @; ?* x# d) R) M0 F# g& J, ^' I
  5、关闭注册表编辑器;. P( o1 B$ {3 k5 v

3 J: d# ]- k8 |* Z$ @  6、重新启动SQL Server服务。1 J7 e* t  c5 D% i/ h$ A- D# R

3 w: l: r; l0 }0 _  H  此时,用户可以成功地使用sa在企业管理器中新建SQL Server注册,但是仍然无法使用Windows身份验证模式来连接SQL Server。这是因为在 SQL Server 中有两个缺省的登录帐户:BUILTIN\Administrators 以及 <机器名>\Administrator 被删除。要恢复这两个帐户,可以使用以下的方法:8 S* m. n, P) T

) d5 k/ z) v; R- T  1、打开企业管理器,展开服务器组,然后展开服务器;
/ i4 O0 f2 I/ ?) ]; u5 g, j
& q. T. b* [( \! m* a. `  u  2、展开"安全性",右击"登录",然后单击"新建登录";
7 u0 C, u* r& G$ O$ G7 N, Q" m" J+ g/ c- R0 c
  3、在"名称"框中,输入 BUILTIN\Administrators;
& R$ T# X7 `2 Q% V
6 q. _7 Z( h0 O3 J' r  A0 |2 K  O  4、在"服务器角色"选项卡中,选择"System Administrators" ;8 U* @1 t2 m7 o/ V/ t- h
. S! P6 \! ~0 d. p1 m  U& r
  5、点击"确定"退出;7 G1 \6 l, L; o0 A) p& l
  G" Y* i: E' l. X* p2 z- A
  6、使用同样方法添加 <机器名>\Administrator 登录。# ?# W6 [0 v; K! ~( o6 ^
/ ?3 [8 q. v" F7 Y
  以下注册表键
1 f! _# @* `# J' g; Z2 U) X2 S
% w/ p5 g9 E; j* w) S+ ], Y, u) m; r( C5 lHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode7 L# @! A7 R- H6 Y4 R

8 E* s" d3 @. O4 X+ G. I  的值决定了SQL Server将采取何种身份验证模式。该值为1,表示使用Windows 身份验证模式;该值为2,表示使用混合模式(Windows 身份验证和 SQL Server 身份验证)。9 }+ T$ e% n7 ~6 \
0 H. m2 u) g! l. y& e
  看完如何解决前两个错误的方法之后,让我们来看一下如图 3 所示的第三个错误。7 n6 Y' H0 J3 d% N
( g8 j' f+ ~8 ]; F# I! A) Q" v
  如果遇到第三个错误,一般而言表示客户端已经找到了这台服务器,并且可以进行连接,不过是由于连接的时间大于允许的时间而导致出错。这种情况一般会发生在当用户在Internet上运行企业管理器来注册另外一台同样在Internet上的服务器,并且是慢速连接时,有可能会导致以上的超时错误。有些情况下,由于局域网的网络问题,也会导致这样的错误。9 @( u( y3 ]2 G% ], W8 N5 {* t7 p
3 m9 o  O, X8 P9 K, }* h
  要解决这样的错误,可以修改客户端的连接超时设置。默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是 4 秒,而查询分析器是 15 秒(这也是为什么在企业管理器里发生错误的可能性比较大的原因)。具体步骤为:) ]: m8 I# s7 B8 ?3 v% C; [* P
& t. ]- R+ p2 q: N9 x; w, Z' c! [5 {! q
  1、在企业管理器中,选择菜单上的"工具",再选择"选项";
* J) _3 F" Q  R4 J) y
: a( ]0 B3 E4 y6 [3 U( N  2、在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡;
- ]0 b. x. T& R" N3 b+ \; Q% O8 M+ H& @& f4 L
  3、在"连接设置"下的"登录超时(秒)"右边的框中输入一个比较大的数字,如 20。
: Z7 K7 Y* R& J% X1 `* z
0 ^) p/ h$ o- y$ h  查询分析器中也可以在同样位置进行设置。 <>
* n& @3 \9 U1 I6 e! u$ A( m5 D* A二、应用程序连接失败
9 V+ W' i( ]& x2 w6 x
/ k4 T: x; V* x% u! I  以上的三种错误信息都是发生在 SQL Server 自带的客户端工具中,在应用程序中我们也会遇到类似的错误信息,例如:
9 q+ o6 D: q* X/ b/ I4 |* C
4 y8 V3 h# t3 b* C+ RMicrosoft OLE DB Provider for SQL Server (0x80004005)8 L7 `, A! L1 B  P1 o
[DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found.
8 Z  R! B: |! Q1 G# }: P
8 h) N. e8 I- I9 {; h/ dMicrosoft OLE DB Provider for SQL Server (0x80004005)
) |' t6 v+ C. J8 N( [5 ]8 {用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。( p- t9 U1 K4 I& Y9 N
$ e) e/ w, S8 [! J% U1 }
Microsoft OLE DB Provider for ODBC Drivers 错误 '80004005'.
$ Z) g$ \, V/ e1 W! ?8 e[Microsoft][ODBC SQL Server Driver]超时已过期.  K% o, d, T* r
7 U- D, I& x2 d3 s
  首先,让我们来详细看以下的示意图来了解一下使用 ODBC 和使用 OLE DB 连接 SQL Server 有什么不同之处。
, X4 W# A; B, C7 S% K& k. Q
$ R0 H: l' Q+ t0 H; f3 j! e4 p  
% Q( h% ^* ?1 X% @, h" R  @
* p3 c+ d1 h* V& v" l9 T% {# B
6 w! Y) f/ @# @2 [4 g  从上图中,我们可以看出在实际使用中,应用程序创建和使用各种 ADO 对象,ADO 对象框架调用享用的 OLE DB 提供者。为了访问 SQL Server 数据库,OLE DB 提供了两种不同的方法:用于 SQL Server 的 OLE DB 提供者以及用于 ODBC 的 OLE DB 提供者。这两种不同的方法对应于两种不同的连接字符串,标准的连接字符串写法如下所示:
# ^) H1 V0 [% ^5 O0 g, }' A9 J/ {7 R4 P& O
  1、使用用于 SQL Server 的 OLE DB 提供者:
7 T# t8 @* S/ R0 T) v# H) n. `6 }& c3 S8 W6 ~
  使用 SQL Server 身份验证:
8 k+ n8 O1 O- K% P5 e; v5 V7 ^( ^
# h$ _, o2 h! i& ^+ C& BoConn.Open "rovider=sqloledb;" &amp; _
, p8 i/ C6 T. |3 h5 ^0 `$ a"Data Source=myServerName;" &amp; _
4 L3 n6 N, W1 @"Initial Catalog=myDatabaseName;" &amp; _
! o# ]7 E% [. t# u# A% ?/ c"User Id=myUsername;" &amp; _
) B9 P0 V' n. s2 i  d"assword=myPassword") b" ^+ D, e  X9 ]& ^; a
# d" h2 W" z! I: ^; _; R, y
  使用 Windows 身份验证(信任连接):# @: p- Y: ]% m" v" R

8 G6 _: \% N: G( ~oConn.Open "rovider=sqloledb;" &amp; _. [9 o' a+ N# T! D
"Data Source=myServerName;" &amp; _5 U) D2 \  W0 y
"Initial Catalog=myDatabaseName;" &amp; _
0 F  {7 e: i7 w$ }9 s"Integrated Security=SSPI"4 b5 o4 b6 F1 |& t; u7 ^; [0 e  C4 ]
3 L5 O) G! N' e
  2、使用用于 ODBC 的 OLE DB 提供者(不使用 ODBC 数据源):$ Z( y& N! e! y' Y
' M* a8 w( `4 Z( k; j. I
  使用 SQL Server 身份验证:, I9 j; A, A/ @

6 a' Y) ?. K3 e7 SoConn.Open "Driver={SQL Server};" &amp; _
6 H. {1 q# n- X3 x"Server=MyServerName;" &amp; _( k3 P% p7 T6 h6 o
"Database=myDatabaseName;" &amp; _
, M* O$ M( D8 D, D& ^- [" L: i"Uid=myUsername;" &amp; _
9 Q8 o  S: h! X, r& Q; D$ G"wd=myPassword", a' h* K# w  y6 |6 ]4 N' i" ^. `

( b3 g6 ~6 S& h0 j  使用 Windows 身份验证(信任连接):% a& w0 ]* Z( W( }

# Z: `5 J7 E8 woConn.Open "Driver={SQL Server};" &amp; _ ) X$ z& N$ Q& f! w& ~; }. S/ v
"Server=MyServerName;" &amp; _
0 k  d& l1 T" C  g, W/ w4 K"Database=myDatabaseName;" &amp; _
/ {" i: d0 m  H+ ~, H7 u. T0 x+ ?"Trusted_Connection=yes"
* R' d8 Z) L: L! a# b) e
9 a3 w' c0 {5 w, Q  3、使用用于 ODBC 的 OLE DB 提供者(使用 ODBC 数据源):5 P6 P0 x2 ]; S* z. ~* u
, Q2 g8 t4 e2 k* H
oConn.Open "DSN=mySystemDSN;" &amp; _
8 D7 t8 `, S  X* p, [* p+ M1 u- ~"Uid=myUsername;" &amp; _ , L$ h* u6 }5 h1 l; e; o
"wd=myPassword"8 k( d9 t- B6 e& G" q
4 {6 N9 |' Q9 H/ h
  如果遇到连接失败的情况,我们只要按照一中所示的方法,结合程序中的连接字符串进行检查,基本都能得到解决。另外,还有以下几个要注意的地方:
" |2 `1 Q# C6 z$ ~$ M7 E' V
$ ]' A7 K: \& c  1、配置 ODBC 数据源时,点击"客户端"配置选项可以让我们指定连接使用的网络库、端口号等属性,如下图所示:
; F. {* W5 W* q. T! P6 W1 ?
( I2 g: e( y: b" h2 u' V; F0 Z  
. G8 _7 j. ]' `- y
) n8 l& T$ N; G2 ?  [/ w. u+ z
8 I5 g& @- ]$ x0 l6 j' t$ d0 k& G5 N8 X
  2、如果遇到连接超时的错误,我们可以在程序中修改 Connection 对象的超时设置,再打开该连接。例如:
( t% s4 A$ V& u- m8 U" |( [& V
1 {6 ~0 f. |5 G</P><>&lt;%
# t, ?0 c7 d4 b( a" z9 fSet Conn = Server.CreateObject("ADODB.Connection")& ?7 W, u# L5 c* j3 c" e
DSNtest="DRIVER={SQL Server};SERVER=ServerName;UID=USERWD=password;DATABASE=mydatabase"
6 E7 r2 K. K7 I* |; B& C  A6 h8 }Conn. Properties("Connect Timeout") = 15 '以秒为单位
: N$ V+ a$ N. Q0 d+ [Conn.open DSNtest7 x9 M  h9 n+ N1 a% D- L
%&gt;</P><>7 L+ G6 G  o" ^$ R! S
  3、如果遇到查询超时的错误,我们可以在程序中修改 Recordset 对象的超时设置,再打开结果集。例如:
) r; x1 M$ r5 @$ l. t5 I) B6 m  A5 ?
7 W$ m& X+ P3 O* {& A! j) q</P><>Dim cn As New ADODB.Connection
9 b' U! G4 N, bDim rs As ADODB.Recordset
5 G4 `3 S1 I2 b  O# G. . . 4 O! c4 V% _7 I+ ^3 U
cmd1 = txtQuery.Text. F& J  p: ^  O8 J* f$ r
Set rs = New ADODB.Recordset" \3 r2 a! y% ^6 F$ ~- N
rs.Properties("Command Time Out") = 300
9 w# b. u5 D& `% I8 x'同样以秒为单位,如果设置为 0 表示无限制
% H* W  A2 E: e) L$ ^rs.Open cmd1, cn7 _0 @% z3 _% s  S
rs.MoveFirst
* k4 T; W! F$ l" J. . . </P><>
- c+ e- r: C8 t! O% p  <B>三、小结</B>
' J4 m! `  }+ N; A% g) n
- m5 l' o! @. h1 ]2 Q# E3 F  本文针对大部分用户在使用 SQL Server 过程中常见的连接失败的错误,重点讨论了在使用 SQL Server 客户端工具以及用户开发的应用程序两种情况下,如何诊断并解决连接失败的错误。看过本文以后,相信每一个读者都会对 SQL Server 的连接工作原理、身份验证方式以及应用程序开发等有一个较为全面而深入的连接。本文中所有的测试或者示例均在 Windows 2000 Advanced Server + SQL Server 2000 企业版上通过。</P>
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册地址

qq
收缩
  • 电话咨询

  • 04714969085
fastpost

关于我们| 联系我们| 诚征英才| 对外合作| 产品服务| QQ

手机版|Archiver| |繁體中文 手机客户端  

蒙公网安备 15010502000194号

Powered by Discuz! X2.5   © 2001-2013 数学建模网-数学中国 ( 蒙ICP备14002410号-3 蒙BBS备-0002号 )     论坛法律顾问:王兆丰

GMT+8, 2026-10-10 03:14 , Processed in 0.451151 second(s), 56 queries .

回顶部