- 在线时间
- 0 小时
- 最后登录
- 2007-9-23
- 注册时间
- 2004-9-10
- 听众数
- 3
- 收听数
- 0
- 能力
- 0 分
- 体力
- 9975 点
- 威望
- 7 点
- 阅读权限
- 150
- 积分
- 4048
- 相册
- 0
- 日志
- 0
- 记录
- 0
- 帖子
- 1893
- 主题
- 823
- 精华
- 2
- 分享
- 0
- 好友
- 0

我的地盘我做主
该用户从未签到
|
单击"别名"选项卡,还可以为服务器配置别名。服务器的别名是用来连接的名称,连接参数中的服务器是真正的服务器名称,两者可以相同或不同。如下图中,我们可以使用myserver来代替真正的服务器名称sql2kcn-02,并且使用网络库 Named Pipes。别名的设置与使用HOSTS文件有相似之处。3 v, H. q9 v3 |. h1 x$ W: N ], ~& M$ I3 D
. y: h7 x7 x0 P7 W
S$ u6 z- ]: J通过以上几个方面的检查,错误 1 发生的原因基本上可以被排除。下面我们再详细描述如何来解决错误 2。
9 \" e' Z0 ^% N, F" i$ k
+ e" p* X8 } W0 t 当用户尝试在查询分析器里面使用sa来连接SQL Server,或者在企业管理器里面使用sa来新建一个SQL Server注册时,经常会遇到如图 2 所示的错误信息。该错误产生的原因是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的登录帐户(如 sa )进行连接。解决方法如下所示:' t3 F8 _9 ^9 V' D
( O: Y! ?# a! D- r' q 1、 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server;
* |# p: w* Z0 x( v' c8 P- C) Y0 _, n9 @. G. K V
2、 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡;
0 {0 K$ v% L) I e$ _5 t* r/ l e( y' a6 o; b8 h( X2 M$ J
3、 在"身份验证"下,选择"SQL Server和 Windows "。 z4 Q; R, }& }+ E( b, }- s
: r: h: k2 o1 Z- y
4、 重新启动SQL Server服务。! A% Q& r4 U; `9 w, l- E. v
+ F1 r3 ^6 c6 M 在以上解决方法中,如果在第 1 步中使用"使用 Windows 身份验证"连接 SQL Server 失败,那么我们将遇到一个两难的境地:首先,服务器只允许了 Windows 的身份验证;其次,即使使用了 Windows 身份验证仍然无法连接上服务器。这种情形被形象地称之为"自己把自己锁在了门外",因为无论用何种方式,用户均无法使用进行连接。实际上,我们可以通过修改一个注册表键值来将身份验证方式改为 SQL Server 和 Windows 混合验证,步骤如下所示:
$ h5 L7 f/ b: v; k0 N
W8 w2 D7 y6 n$ I" [, O 1、点击"开始"-"运行",输入regedit,回车进入注册表编辑器;
. _2 h! ^% F7 S |7 B; T7 J5 R
$ C/ b$ L2 ]! a1 T 2、依次展开注册表项,浏览到以下注册表键:. T) K) f+ Y7 |$ C9 h
( y& ?5 j. O% N
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]# ~& U$ N0 V+ ~. F1 ^
d a# r6 j8 M h6 \) H 3、在屏幕右方找到名称"LoginMode",双击编辑双字节值;
, S, T$ {2 x! o4 V- R
! F: W8 v$ E1 w: C4 l 4、将原值从1改为2,点击"确定";2 i3 b$ J) F* }# l' X
" a6 o" P* A8 A, j' z6 X- i: g5 _ 5、关闭注册表编辑器;
% I" k$ [) ^9 Z2 a2 o h9 @
9 w. n8 d/ N1 @" }6 F1 P 6、重新启动SQL Server服务。( n* J) v! }4 i- G9 j1 E) J
+ J: U1 l- E1 U. R, p$ ? 此时,用户可以成功地使用sa在企业管理器中新建SQL Server注册,但是仍然无法使用Windows身份验证模式来连接SQL Server。这是因为在 SQL Server 中有两个缺省的登录帐户:BUILTIN\Administrators 以及 <机器名>\Administrator 被删除。要恢复这两个帐户,可以使用以下的方法:" z% s- E, _ D) d! f3 r
" D* j. J) }9 ^9 |2 [2 ~
1、打开企业管理器,展开服务器组,然后展开服务器;
: _: q* m; }7 K' v/ y. m6 t
1 K( _3 n" o5 x" ]% x 2、展开"安全性",右击"登录",然后单击"新建登录";
" I( y2 ?2 n% O* W* Z
o& V% i/ y7 U8 |1 j 3、在"名称"框中,输入 BUILTIN\Administrators;
?& K+ D& Q; W v: u; ^7 x4 n. p8 ]( \+ N6 r& c7 t/ v
4、在"服务器角色"选项卡中,选择"System Administrators" ;4 e% v: }" o3 z% x) \
" w, ?4 D+ J0 L
5、点击"确定"退出;5 y6 @/ Z: I' Q5 ]9 ]4 L2 p1 F
0 Z6 M; F6 E( p& ~8 Y9 Q5 d 6、使用同样方法添加 <机器名>\Administrator 登录。
! a& w1 k1 S( v" w
* t5 z7 P E& P5 L2 d 以下注册表键
# F* D& @8 R2 b/ [5 P3 Q: R* j4 m- T }
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode- H% f, A& {. }7 O/ Y8 t0 v" z
1 g- o# N7 r3 b" U" _- L( G/ J" a 的值决定了SQL Server将采取何种身份验证模式。该值为1,表示使用Windows 身份验证模式;该值为2,表示使用混合模式(Windows 身份验证和 SQL Server 身份验证)。3 i" i; X2 r+ R& ?1 |( A5 S* N
9 v7 K# z4 x. E1 u 看完如何解决前两个错误的方法之后,让我们来看一下如图 3 所示的第三个错误。
2 B4 C3 w( D- o$ A0 m6 ^$ U8 E# p, E1 C d1 a
如果遇到第三个错误,一般而言表示客户端已经找到了这台服务器,并且可以进行连接,不过是由于连接的时间大于允许的时间而导致出错。这种情况一般会发生在当用户在Internet上运行企业管理器来注册另外一台同样在Internet上的服务器,并且是慢速连接时,有可能会导致以上的超时错误。有些情况下,由于局域网的网络问题,也会导致这样的错误。
& X2 i% \3 X& ]5 c$ }
/ u3 s: e4 N+ a 要解决这样的错误,可以修改客户端的连接超时设置。默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是 4 秒,而查询分析器是 15 秒(这也是为什么在企业管理器里发生错误的可能性比较大的原因)。具体步骤为:# j$ x% i1 g7 f! f8 n
5 w$ K% T0 s) [ 1、在企业管理器中,选择菜单上的"工具",再选择"选项";
/ J7 g* S4 P o2 c7 @/ z9 O: a h# i- Q* {! P
2、在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡;$ M C3 U( S) A. T# n) x
% y2 [3 D3 B+ O% }8 N7 X) k
3、在"连接设置"下的"登录超时(秒)"右边的框中输入一个比较大的数字,如 20。6 g. q. K) x0 J5 X3 z9 b5 q+ C
# a1 V$ L; W# X/ a3 e8 J I 查询分析器中也可以在同样位置进行设置。 < >4 w ?" g9 t) u( N
二、应用程序连接失败
; S3 J# m* N; l
5 M# a+ l- l) d3 n v 以上的三种错误信息都是发生在 SQL Server 自带的客户端工具中,在应用程序中我们也会遇到类似的错误信息,例如:
9 A4 w/ V! a3 t% Q/ Z; Y7 @. F1 r8 l- \% U3 \" ^. e# B$ R
Microsoft OLE DB Provider for SQL Server (0x80004005)/ j3 \$ _7 }+ S6 K5 X
[DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found.+ }# l* K( p! v
- P$ U% z5 N1 C* `5 V) |Microsoft OLE DB Provider for SQL Server (0x80004005)# ~( D, R4 q/ V3 }) H# n! E$ t
用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。
4 H q& C7 s, e* z8 V4 V6 G! T9 M* `0 |" Z7 U
Microsoft OLE DB Provider for ODBC Drivers 错误 '80004005'.+ s9 j0 m2 { W% G' G5 A
[Microsoft][ODBC SQL Server Driver]超时已过期.
y6 s2 q5 w0 y5 g
. {8 j. A4 O# }3 | 首先,让我们来详细看以下的示意图来了解一下使用 ODBC 和使用 OLE DB 连接 SQL Server 有什么不同之处。
8 e/ @- c# O) C! o. }. o' i( |4 ?. D
( g/ d+ J: S3 W/ ^3 G
) k3 H4 c% n `) g3 B/ B! {2 T! ?, N% O. ?4 f5 r4 s9 p; N3 Y
从上图中,我们可以看出在实际使用中,应用程序创建和使用各种 ADO 对象,ADO 对象框架调用享用的 OLE DB 提供者。为了访问 SQL Server 数据库,OLE DB 提供了两种不同的方法:用于 SQL Server 的 OLE DB 提供者以及用于 ODBC 的 OLE DB 提供者。这两种不同的方法对应于两种不同的连接字符串,标准的连接字符串写法如下所示:& A% X& x4 r( j {- }9 q+ U
3 D' w# J5 b! W( q, z# R* e; ?
1、使用用于 SQL Server 的 OLE DB 提供者:8 w, j' _: Y0 H+ X0 I( g
0 B2 l8 Y- l3 v+ x, b3 N* c. D; J 使用 SQL Server 身份验证:0 A" \( a( o$ P- C7 U! p1 z+ ^ p
( `# u8 ]% s' S- V0 j& F3 woConn.Open " rovider=sqloledb;" & _
- V5 t" V$ u- l4 ~4 w; c7 d8 H"Data Source=myServerName;" & _
, r, {( `% g7 w) U) `"Initial Catalog=myDatabaseName;" & _/ X$ {9 r; i# Q* L3 E
"User Id=myUsername;" & _
" j/ i/ J' W( a8 z3 }" assword=myPassword"' v& E, C2 ~8 o6 j
5 x0 g4 C0 ? b3 k* s5 M5 s, c
使用 Windows 身份验证(信任连接):- s& m$ S) `6 V# u1 \% C
1 R, R& b; x! O2 W. k! PoConn.Open " rovider=sqloledb;" & _
# U) y8 x6 U* l. N8 g1 H"Data Source=myServerName;" & _! d) }$ S' k4 ?$ }* I* S
"Initial Catalog=myDatabaseName;" & _
4 w; j5 C* h- h/ w1 j6 g"Integrated Security=SSPI"% N& B$ F' f& g( P1 a& L( B6 [4 e% H
; y$ @$ f9 p! ?' U- o 2、使用用于 ODBC 的 OLE DB 提供者(不使用 ODBC 数据源):
* H$ F9 X) {# k4 s; R) q# J& L: ?9 H5 y: M, ^- ~( U5 s
使用 SQL Server 身份验证:
% y8 y, n* T @4 ^. D3 T# _; V4 n1 |6 a
oConn.Open "Driver={SQL Server};" & _ 4 g* X1 W, T6 ]" j% b+ l4 c0 x
"Server=MyServerName;" & _
4 ^5 ~) c" }& J" Y6 f; N2 |"Database=myDatabaseName;" & _
: J. E' C! o: J0 S" C"Uid=myUsername;" & _
4 s8 _/ o ~" [$ N& e7 M; Z" wd=myPassword"+ X; \* M# [. ?- Q
$ `) b* Y( P& e% [4 K
使用 Windows 身份验证(信任连接):
# Q$ h: H7 A9 g# _" ]! T0 y- V5 T2 X) v) b7 v4 J2 q% W0 S- V
oConn.Open "Driver={SQL Server};" & _ ! E8 U9 @9 A; Z, }& ?+ `
"Server=MyServerName;" & _
3 D; S w+ o- K8 h"Database=myDatabaseName;" & _
/ b: ^ c+ _; q: X"Trusted_Connection=yes"
* K& g: I( W1 p6 Z3 X+ F. e- |
: x4 ^. x9 s! F' G: ^! t: e 3、使用用于 ODBC 的 OLE DB 提供者(使用 ODBC 数据源):
& M6 I2 J; B* b# p+ M. j9 e, S
p8 ^8 C. W2 E2 noConn.Open "DSN=mySystemDSN;" & _ ' h9 E1 O2 a8 F2 j0 |; C7 F
"Uid=myUsername;" & _
3 {$ e2 R2 s V# \4 Y7 e' E0 O" wd=myPassword"0 t# ^$ ?$ l6 r
! p& g' c" L% G9 {# m3 [' ~1 n
如果遇到连接失败的情况,我们只要按照一中所示的方法,结合程序中的连接字符串进行检查,基本都能得到解决。另外,还有以下几个要注意的地方:* c0 E' K# U6 s
4 S; w0 Y; m8 }4 |* W i& \9 F 1、配置 ODBC 数据源时,点击"客户端"配置选项可以让我们指定连接使用的网络库、端口号等属性,如下图所示:4 E' X% @( B) Y7 S; {% r' d
% K' A H1 n) f8 m9 `# ?5 ^5 ~
! ^, o; q" b& {% ^1 D6 h/ m/ ?# q
' W E( y1 w( z$ O( |% I8 |" a* F; U6 J6 C0 I% G
4 R! f5 P# M/ P( A 2、如果遇到连接超时的错误,我们可以在程序中修改 Connection 对象的超时设置,再打开该连接。例如:
1 X! ^- r3 y: c2 R' Z: N/ ?
# c; e0 V+ T5 e U; z</P>< ><%0 w: J: p: \8 s
Set Conn = Server.CreateObject("ADODB.Connection")* ], N5 x0 B5 n. m+ e6 `# t f
DSNtest="DRIVER={SQL Server};SERVER=ServerName;UID=USER WD=password;DATABASE=mydatabase"
; {9 A& U# a$ W% Q/ l* P6 ^Conn. Properties("Connect Timeout") = 15 '以秒为单位
: h: _ d6 Z; }0 iConn.open DSNtest m% m9 `6 V/ q/ W. c* a0 q# G) L( p
%></P>< >" p, O+ p# Y+ ~/ ^' _4 l. {
3、如果遇到查询超时的错误,我们可以在程序中修改 Recordset 对象的超时设置,再打开结果集。例如:! |7 m$ F$ b3 b8 Z+ F' X; n, M
6 ?8 B+ Q! ^8 K7 I/ j% a, P</P>< >Dim cn As New ADODB.Connection2 J/ Z' G; J2 ]* R* M( u
Dim rs As ADODB.Recordset
: w$ V2 F1 P# ^4 V' _7 P, A) W. . .
0 R1 X+ a P. F" ]4 @/ ]cmd1 = txtQuery.Text
: y1 q# Q6 i k& {" i* iSet rs = New ADODB.Recordset
; x) v- T6 Q+ g+ p8 ]- C5 N7 {9 X( q3 Srs.Properties("Command Time Out") = 300
+ S: F% i: A$ _% t9 Z# q'同样以秒为单位,如果设置为 0 表示无限制5 z; _0 I0 g$ B
rs.Open cmd1, cn
0 }! S7 F( u- r. Q3 f X% ~rs.MoveFirst
0 p3 p/ C& D5 G4 f' u. . . </P>< >6 Y+ p/ j5 R( \) K
<B>三、小结</B>
+ I: {; e* x' \6 q+ i# X9 P4 l. ^" a0 S" l
* M- \' E8 e/ i9 A 本文针对大部分用户在使用 SQL Server 过程中常见的连接失败的错误,重点讨论了在使用 SQL Server 客户端工具以及用户开发的应用程序两种情况下,如何诊断并解决连接失败的错误。看过本文以后,相信每一个读者都会对 SQL Server 的连接工作原理、身份验证方式以及应用程序开发等有一个较为全面而深入的连接。本文中所有的测试或者示例均在 Windows 2000 Advanced Server + SQL Server 2000 企业版上通过。</P> |
|