QQ登录

只需要一步,快速开始

 注册地址  找回密码
查看: 5218|回复: 1
打印 上一主题 下一主题

SQL Server连接失败错误及解决

[复制链接]
字体大小: 正常 放大
韩冰        

823

主题

3

听众

4048

积分

我的地盘我做主

该用户从未签到

发帖功臣 元老勋章

跳转到指定楼层
1#
发表于 2004-11-19 10:28 |只看该作者 |正序浏览
|招呼Ta 关注Ta
在使用 SQL Server 的过程中,用户遇到的最多的问题莫过于连接失败了。一般而言,有以下两种连接 SQL Server 的方式,一是利用 SQL Server 自带的客户端工具,如企业管理器、查询分析器、事务探查器等;二是利用用户自己开发的客户端程序,如ASP 脚本、VB程序等,客户端程序中又是利用 ODBC 或者 OLE DB 等连接 SQL Server。下面,我们将就这两种连接方式,具体谈谈如何来解决连接失败的问题。. t5 }( N7 u9 P, s/ m

5 y7 }$ y1 B1 y  一、客户端工具连接失败
4 n( u' d: W; U, I1 x
% E+ h, C5 w  D. F0 M  在使用 SQL Server 自带的客户端工具(以企业管理器为例)连接 SQL Server时,最常见的错误有如下一些:
' b# Y' |( W8 j) U* `% y
3 n8 {6 w# p3 O5 M  1、SQL Server 不存在或访问被拒绝/ b' b, K* q0 l. R+ M
6 N9 q) p( A" n" T1 W  e) F
    ConnectionOpen (Connect()): K. d0 L+ ?' m/ Q

: b% u0 Q1 T$ e4 e. _9 o, J  
* y2 f1 o# v- J0 }2 J: ?& F3 D2 O% k9 ^2 ?
2 s" w% J1 f; U, k  S; }' ]2 u* T

; M- T/ e1 d7 T
6 x5 P1 G% V; Y4 z  2、用户'sa'登录失败。原因:未与信任 SQL Server 连接相关联。$ F8 I' f4 I1 F( P5 g

5 L, u) s; m/ Y  2 h+ W! l/ l& Y7 d; Y9 [6 s; L

9 g1 L; l4 m7 Z: W5 [7 h5 A! B4 \6 t' v
0 T  c! q. r5 s& ?8 p! k4 n) l
. p( L( P. M5 H2 Y5 S5 n" t
! K/ ^' T* C& N2 e  3、超时已过期。0 h3 N3 N4 B5 F+ ?% N
# F! Z2 A  M( N0 `/ N
   + e, q3 A6 R5 n9 M* x& u+ l) p

/ ?+ ^: M! z/ N/ X
3 R, M6 w2 M3 D& M1 Y' l0 l& @下面我们依次介绍如何来解决这三个最常见的连接错误。
# z8 S$ R( s' t
6 I- W' ~0 d/ `5 Z" w  第一个错误"SQL Server 不存在或访问被拒绝"通常是最复杂的,错误发生的原因比较多,需要检查的方面也比较多。一般说来,有以下几种可能性:
5 B3 K* _3 z6 H- o
/ E2 v! j: Z) h, \8 Q% m" S  1、SQL Server名称或IP地址拼写有误;
/ e. G' Z2 K& d& |+ F) g, s- R4 c' |: Z
  2、服务器端网络配置有误;3 s6 J% ^; C9 S
% ?( N/ w$ u; b' ]2 m' f: ~2 ?1 _& h
  3、客户端网络配置有误。
6 {! b8 k/ F( a  @1 h* d& i$ u- W& d) {
  要解决这个问题,我们一般要遵循以下的步骤来一步步找出导致错误的原因。5 Z# `) @/ [# Q+ C1 ^
0 }7 z, M1 y& ~$ O( B- v; P; _3 s
  首先,检查网络物理连接:
: i7 o( X7 e  B& e* R4 O, q
9 z; F" y, Q8 f: l   ping <服务器IP地址> " x( Z* `% Q. n9 |
 
% |. Q( p5 B4 R4 u1 f7 G9 u  P  或者: w7 o+ s0 ~+ H3 s! @

+ u( r; x6 x5 c* U( O/ S) v3 I   ping <服务器名称>
6 E: I* T, `9 a/ {
' [+ p8 V9 ]0 |. q  如果 ping <服务器IP地址> 失败,说明物理连接有问题,这时候要检查硬件设备,如网卡、HUB、路由器等。还有一种可能是由于客户端和服务器之间安装有防火墙软件造成的,比如 ISA Server。防火墙软件可能会屏蔽对 ping、telnet 等的响应,因此在检查连接问题的时候,我们要先把防火墙软件暂时关闭,或者打开所有被封闭的端口。
5 K# e( K  Y6 r" {) `3 e
7 U% ?7 U+ Y( U  如果ping <服务器IP地址> 成功而 ping <服务器名称> 失败,则说明名字解析有问题,这时候要检查 DNS 服务是否正常。有时候客户端和服务器不在同一个局域网里面,这时候很可能无法直接使用服务器名称来标识该服务器,这时候我们可以使用HOSTS文件来进行名字解析,具体的方法是:5 _: @7 J. Y. P) b9 z" l
3 g& r' A* ?  [0 ~
  1、使用记事本打开HOSTS文件(一般情况下位于C:\WINNT\system32\drivers\etc).3 H7 u/ @3 K& P% ]. i$ x7 n1 m

+ p3 u% v0 K4 c3 [* P6 j6 u9 ^6 E  2、添加一条IP地址与服务器名称的对应记录,如:
4 V* c6 {* W3 v; m" ^: t9 {+ c* M2 h, k; j- t3 ~
    172.168.10.24 myserver
4 Z( p. E  T6 G0 U- v- Z: K7 K5 E5 ]3 q  ^: \/ m0 q% H
  也可以在 SQL Server 的客户端网络实用工具里面进行配置,后面会有详细说明。$ ?" f* l& o. h

6 P9 }: S- x7 Y' C  其次,使用 telnet 命令检查SQL Server服务器工作状态:- I) k) S7 H2 C& D! r% u8 i: p% N% t

$ g% H- U$ q: y: U+ [- W   telnet <服务器IP地址> 1433% h! j1 n6 Y$ I* k

. j" W! k7 o: N1 K0 X% u- D  如果命令执行成功,可以看到屏幕一闪之后光标在左上角不停闪动,这说明 SQL Server 服务器工作正常,并且正在监听1433端口的 TCP/IP 连接;如果命令返回"无法打开连接"的错误信息,则说明服务器端没有启动 SQL Server 服务,也可能服务器端没启用 TCP/IP 协议,或者服务器端没有在 SQL Server 默认的端口1433上监听。
( m7 @4 b# m  Q. j- `6 H5 ]6 r& v) _$ ?* ~, |  o
  接着,我们要到服务器上检查服务器端的网络配置,检查是否启用了命名管道,是否启用了 TCP/IP 协议等等。我们可以利用 SQL Server 自带的服务器网络使用工具来进行检查。0 m9 ~) J1 j  [

( P: Z9 l) ^) I8 d" {7 f7 H  点击:程序 -> Microsoft SQL Server -> 服务器网络使用工具,打开该工具后看到的画面如下图所示:, b5 \' X$ b; R2 d6 a4 v
9 t, {1 Q: A5 j5 y8 R
  6 b: K0 w3 ]' y" E$ l; I
  h& E9 A4 j, c1 n$ T8 \( D

7 B" R7 o# r8 Z, d2 E. X  L+ {& P  从这里我们可以看到服务器启用了哪些协议。一般而言,我们启用命名管道以及 TCP/IP 协议。/ x" @% X) u$ e% j5 b  a

& }# p+ j4 V5 x) a  点中 TCP/IP 协议,选择"属性",我们可以来检查 SQK Server 服务默认端口的设置,如下图所示:$ v1 z, r( r- v# V: `* k; ]. j
6 M9 ?- G1 Y' X+ @( E: V5 P9 h
  5 V' y% p/ Q& ~
- k; j) G+ v* l
+ `5 o/ g  ?5 v
( k* j* @6 q9 q) E
/ X' C  s4 v1 J3 v4 j, S
  一般而言,我们使用 SQL Server 默认的1433端口。如果选中"隐藏服务器",则意味着客户端无法通过枚举服务器来看到这台服务器,起到了保护的作用,但不影响连接。4 n3 Z. d( \0 w0 \" R: D) L8 [
# t8 ~7 e. b/ `+ \
  检查完了服务器端的网络配置,接下来我们要到客户端检查客户端的网络配置。我们同样可以利用 SQL Server 自带的客户端网络使用工具来进行检查,所不同的是这次是在客户端来运行这个工具。
) o! F9 ^0 A+ X' s# _! w6 I
% t& F; v0 `% _7 }  点击:程序 -> Microsoft SQL Server -> 客户端网络使用工具, 打开该工具后看到的画面如下图所示:0 O) U2 ?% k( ]8 {& \) H0 w" `8 s$ x

6 p, s* ~9 L8 p$ o$ V  
/ p9 n  S/ _6 k) c' j; b6 X) i- W" L( f2 x# n
  Z9 r/ ~: {, z8 z8 P/ n1 b
  从这里我们可以看到客户端启用了哪些协议。一般而言,我们同样需要启用命名管道以及 TCP/IP 协议。# }3 V0 T% u2 y& ]

" U1 V* ^8 Q- }, e" q  点击 TCP/IP 协议,选择"属性",可以检查客户端默认连接端口的设置,如下图所示。/ s1 d! L5 ?' W

; _' r$ G& O' }; T% g: u% _  4 ?" e/ R9 }; @

5 b2 j/ o) p0 [" k" Q7 U- S& r$ ~
9 x8 K" S4 F# w6 U! H6 y  该端口必须与服务器一致。
zan
转播转播0 分享淘帖0 分享分享0 收藏收藏0 支持支持0 反对反对0 微信微信
韩冰        

823

主题

3

听众

4048

积分

我的地盘我做主

该用户从未签到

发帖功臣 元老勋章

单击"别名"选项卡,还可以为服务器配置别名。服务器的别名是用来连接的名称,连接参数中的服务器是真正的服务器名称,两者可以相同或不同。如下图中,我们可以使用myserver来代替真正的服务器名称sql2kcn-02,并且使用网络库 Named Pipes。别名的设置与使用HOSTS文件有相似之处。3 v, H. q9 v3 |. h1 x$ W: N  ], ~& M$ I3 D

. y: h7 x7 x0 P7 W  
  S$ u6 z- ]: J通过以上几个方面的检查,错误 1 发生的原因基本上可以被排除。下面我们再详细描述如何来解决错误 2。
9 \" e' Z0 ^% N, F" i$ k
+ e" p* X8 }  W0 t  当用户尝试在查询分析器里面使用sa来连接SQL Server,或者在企业管理器里面使用sa来新建一个SQL Server注册时,经常会遇到如图 2 所示的错误信息。该错误产生的原因是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的登录帐户(如 sa )进行连接。解决方法如下所示:' t3 F8 _9 ^9 V' D

( O: Y! ?# a! D- r' q  1、 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server;
* |# p: w* Z0 x( v' c8 P- C) Y0 _, n9 @. G. K  V
  2、 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡;
0 {0 K$ v% L) I  e$ _5 t* r/ l  e( y' a6 o; b8 h( X2 M$ J
  3、 在"身份验证"下,选择"SQL Server和 Windows "。  z4 Q; R, }& }+ E( b, }- s
: r: h: k2 o1 Z- y
  4、 重新启动SQL Server服务。! A% Q& r4 U; `9 w, l- E. v

+ F1 r3 ^6 c6 M  在以上解决方法中,如果在第 1 步中使用"使用 Windows 身份验证"连接 SQL Server 失败,那么我们将遇到一个两难的境地:首先,服务器只允许了 Windows 的身份验证;其次,即使使用了 Windows 身份验证仍然无法连接上服务器。这种情形被形象地称之为"自己把自己锁在了门外",因为无论用何种方式,用户均无法使用进行连接。实际上,我们可以通过修改一个注册表键值来将身份验证方式改为 SQL Server 和 Windows 混合验证,步骤如下所示:
$ h5 L7 f/ b: v; k0 N
  W8 w2 D7 y6 n$ I" [, O  1、点击"开始"-"运行",输入regedit,回车进入注册表编辑器;
. _2 h! ^% F7 S  |7 B; T7 J5 R
$ C/ b$ L2 ]! a1 T  2、依次展开注册表项,浏览到以下注册表键:. T) K) f+ Y7 |$ C9 h
( y& ?5 j. O% N
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]# ~& U$ N0 V+ ~. F1 ^

  d  a# r6 j8 M  h6 \) H  3、在屏幕右方找到名称"LoginMode",双击编辑双字节值;
, S, T$ {2 x! o4 V- R
! F: W8 v$ E1 w: C4 l  4、将原值从1改为2,点击"确定";2 i3 b$ J) F* }# l' X

" a6 o" P* A8 A, j' z6 X- i: g5 _  5、关闭注册表编辑器;
% I" k$ [) ^9 Z2 a2 o  h9 @
9 w. n8 d/ N1 @" }6 F1 P  6、重新启动SQL Server服务。( n* J) v! }4 i- G9 j1 E) J

+ J: U1 l- E1 U. R, p$ ?  此时,用户可以成功地使用sa在企业管理器中新建SQL Server注册,但是仍然无法使用Windows身份验证模式来连接SQL Server。这是因为在 SQL Server 中有两个缺省的登录帐户:BUILTIN\Administrators 以及 <机器名>\Administrator 被删除。要恢复这两个帐户,可以使用以下的方法:" z% s- E, _  D) d! f3 r
" D* j. J) }9 ^9 |2 [2 ~
  1、打开企业管理器,展开服务器组,然后展开服务器;
: _: q* m; }7 K' v/ y. m6 t
1 K( _3 n" o5 x" ]% x  2、展开"安全性",右击"登录",然后单击"新建登录";
" I( y2 ?2 n% O* W* Z
  o& V% i/ y7 U8 |1 j  3、在"名称"框中,输入 BUILTIN\Administrators;
  ?& K+ D& Q; W  v: u; ^7 x4 n. p8 ]( \+ N6 r& c7 t/ v
  4、在"服务器角色"选项卡中,选择"System Administrators" ;4 e% v: }" o3 z% x) \
" w, ?4 D+ J0 L
  5、点击"确定"退出;5 y6 @/ Z: I' Q5 ]9 ]4 L2 p1 F

0 Z6 M; F6 E( p& ~8 Y9 Q5 d  6、使用同样方法添加 <机器名>\Administrator 登录。
! a& w1 k1 S( v" w
* t5 z7 P  E& P5 L2 d  以下注册表键
# F* D& @8 R2 b/ [5 P3 Q: R* j4 m- T  }
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode- H% f, A& {. }7 O/ Y8 t0 v" z

1 g- o# N7 r3 b" U" _- L( G/ J" a  的值决定了SQL Server将采取何种身份验证模式。该值为1,表示使用Windows 身份验证模式;该值为2,表示使用混合模式(Windows 身份验证和 SQL Server 身份验证)。3 i" i; X2 r+ R& ?1 |( A5 S* N

9 v7 K# z4 x. E1 u  看完如何解决前两个错误的方法之后,让我们来看一下如图 3 所示的第三个错误。
2 B4 C3 w( D- o$ A0 m6 ^$ U8 E# p, E1 C  d1 a
  如果遇到第三个错误,一般而言表示客户端已经找到了这台服务器,并且可以进行连接,不过是由于连接的时间大于允许的时间而导致出错。这种情况一般会发生在当用户在Internet上运行企业管理器来注册另外一台同样在Internet上的服务器,并且是慢速连接时,有可能会导致以上的超时错误。有些情况下,由于局域网的网络问题,也会导致这样的错误。
& X2 i% \3 X& ]5 c$ }
/ u3 s: e4 N+ a  要解决这样的错误,可以修改客户端的连接超时设置。默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是 4 秒,而查询分析器是 15 秒(这也是为什么在企业管理器里发生错误的可能性比较大的原因)。具体步骤为:# j$ x% i1 g7 f! f8 n

5 w$ K% T0 s) [  1、在企业管理器中,选择菜单上的"工具",再选择"选项";
/ J7 g* S4 P  o2 c7 @/ z9 O: a  h# i- Q* {! P
  2、在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡;$ M  C3 U( S) A. T# n) x
% y2 [3 D3 B+ O% }8 N7 X) k
  3、在"连接设置"下的"登录超时(秒)"右边的框中输入一个比较大的数字,如 20。6 g. q. K) x0 J5 X3 z9 b5 q+ C

# a1 V$ L; W# X/ a3 e8 J  I  查询分析器中也可以在同样位置进行设置。 <>4 w  ?" g9 t) u( N
二、应用程序连接失败
; S3 J# m* N; l
5 M# a+ l- l) d3 n  v  以上的三种错误信息都是发生在 SQL Server 自带的客户端工具中,在应用程序中我们也会遇到类似的错误信息,例如:
9 A4 w/ V! a3 t% Q/ Z; Y7 @. F1 r8 l- \% U3 \" ^. e# B$ R
Microsoft OLE DB Provider for SQL Server (0x80004005)/ j3 \$ _7 }+ S6 K5 X
[DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found.+ }# l* K( p! v

- P$ U% z5 N1 C* `5 V) |Microsoft OLE DB Provider for SQL Server (0x80004005)# ~( D, R4 q/ V3 }) H# n! E$ t
用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。
4 H  q& C7 s, e* z8 V4 V6 G! T9 M* `0 |" Z7 U
Microsoft OLE DB Provider for ODBC Drivers 错误 '80004005'.+ s9 j0 m2 {  W% G' G5 A
[Microsoft][ODBC SQL Server Driver]超时已过期.
  y6 s2 q5 w0 y5 g
. {8 j. A4 O# }3 |  首先,让我们来详细看以下的示意图来了解一下使用 ODBC 和使用 OLE DB 连接 SQL Server 有什么不同之处。
8 e/ @- c# O) C! o. }. o' i( |4 ?. D
   ( g/ d+ J: S3 W/ ^3 G

) k3 H4 c% n  `) g3 B/ B! {2 T! ?, N% O. ?4 f5 r4 s9 p; N3 Y
  从上图中,我们可以看出在实际使用中,应用程序创建和使用各种 ADO 对象,ADO 对象框架调用享用的 OLE DB 提供者。为了访问 SQL Server 数据库,OLE DB 提供了两种不同的方法:用于 SQL Server 的 OLE DB 提供者以及用于 ODBC 的 OLE DB 提供者。这两种不同的方法对应于两种不同的连接字符串,标准的连接字符串写法如下所示:& A% X& x4 r( j  {- }9 q+ U
3 D' w# J5 b! W( q, z# R* e; ?
  1、使用用于 SQL Server 的 OLE DB 提供者:8 w, j' _: Y0 H+ X0 I( g

0 B2 l8 Y- l3 v+ x, b3 N* c. D; J  使用 SQL Server 身份验证:0 A" \( a( o$ P- C7 U! p1 z+ ^  p

( `# u8 ]% s' S- V0 j& F3 woConn.Open "rovider=sqloledb;" &amp; _
- V5 t" V$ u- l4 ~4 w; c7 d8 H"Data Source=myServerName;" &amp; _
, r, {( `% g7 w) U) `"Initial Catalog=myDatabaseName;" &amp; _/ X$ {9 r; i# Q* L3 E
"User Id=myUsername;" &amp; _
" j/ i/ J' W( a8 z3 }"assword=myPassword"' v& E, C2 ~8 o6 j
5 x0 g4 C0 ?  b3 k* s5 M5 s, c
  使用 Windows 身份验证(信任连接):- s& m$ S) `6 V# u1 \% C

1 R, R& b; x! O2 W. k! PoConn.Open "rovider=sqloledb;" &amp; _
# U) y8 x6 U* l. N8 g1 H"Data Source=myServerName;" &amp; _! d) }$ S' k4 ?$ }* I* S
"Initial Catalog=myDatabaseName;" &amp; _
4 w; j5 C* h- h/ w1 j6 g"Integrated Security=SSPI"% N& B$ F' f& g( P1 a& L( B6 [4 e% H

; y$ @$ f9 p! ?' U- o  2、使用用于 ODBC 的 OLE DB 提供者(不使用 ODBC 数据源):
* H$ F9 X) {# k4 s; R) q# J& L: ?9 H5 y: M, ^- ~( U5 s
  使用 SQL Server 身份验证:
% y8 y, n* T  @4 ^. D3 T# _; V4 n1 |6 a
oConn.Open "Driver={SQL Server};" &amp; _ 4 g* X1 W, T6 ]" j% b+ l4 c0 x
"Server=MyServerName;" &amp; _
4 ^5 ~) c" }& J" Y6 f; N2 |"Database=myDatabaseName;" &amp; _
: J. E' C! o: J0 S" C"Uid=myUsername;" &amp; _
4 s8 _/ o  ~" [$ N& e7 M; Z"wd=myPassword"+ X; \* M# [. ?- Q
$ `) b* Y( P& e% [4 K
  使用 Windows 身份验证(信任连接):
# Q$ h: H7 A9 g# _" ]! T0 y- V5 T2 X) v) b7 v4 J2 q% W0 S- V
oConn.Open "Driver={SQL Server};" &amp; _ ! E8 U9 @9 A; Z, }& ?+ `
"Server=MyServerName;" &amp; _
3 D; S  w+ o- K8 h"Database=myDatabaseName;" &amp; _
/ b: ^  c+ _; q: X"Trusted_Connection=yes"
* K& g: I( W1 p6 Z3 X+ F. e- |
: x4 ^. x9 s! F' G: ^! t: e  3、使用用于 ODBC 的 OLE DB 提供者(使用 ODBC 数据源):
& M6 I2 J; B* b# p+ M. j9 e, S
  p8 ^8 C. W2 E2 noConn.Open "DSN=mySystemDSN;" &amp; _ ' h9 E1 O2 a8 F2 j0 |; C7 F
"Uid=myUsername;" &amp; _
3 {$ e2 R2 s  V# \4 Y7 e' E0 O"wd=myPassword"0 t# ^$ ?$ l6 r
! p& g' c" L% G9 {# m3 [' ~1 n
  如果遇到连接失败的情况,我们只要按照一中所示的方法,结合程序中的连接字符串进行检查,基本都能得到解决。另外,还有以下几个要注意的地方:* c0 E' K# U6 s

4 S; w0 Y; m8 }4 |* W  i& \9 F  1、配置 ODBC 数据源时,点击"客户端"配置选项可以让我们指定连接使用的网络库、端口号等属性,如下图所示:4 E' X% @( B) Y7 S; {% r' d
% K' A  H1 n) f8 m9 `# ?5 ^5 ~
  
! ^, o; q" b& {% ^1 D6 h/ m/ ?# q
' W  E( y1 w( z$ O( |% I8 |" a* F; U6 J6 C0 I% G

4 R! f5 P# M/ P( A  2、如果遇到连接超时的错误,我们可以在程序中修改 Connection 对象的超时设置,再打开该连接。例如:
1 X! ^- r3 y: c2 R' Z: N/ ?
# c; e0 V+ T5 e  U; z</P><>&lt;%0 w: J: p: \8 s
Set Conn = Server.CreateObject("ADODB.Connection")* ], N5 x0 B5 n. m+ e6 `# t  f
DSNtest="DRIVER={SQL Server};SERVER=ServerName;UID=USERWD=password;DATABASE=mydatabase"
; {9 A& U# a$ W% Q/ l* P6 ^Conn. Properties("Connect Timeout") = 15 '以秒为单位
: h: _  d6 Z; }0 iConn.open DSNtest  m% m9 `6 V/ q/ W. c* a0 q# G) L( p
%&gt;</P><>" p, O+ p# Y+ ~/ ^' _4 l. {
  3、如果遇到查询超时的错误,我们可以在程序中修改 Recordset 对象的超时设置,再打开结果集。例如:! |7 m$ F$ b3 b8 Z+ F' X; n, M

6 ?8 B+ Q! ^8 K7 I/ j% a, P</P><>Dim cn As New ADODB.Connection2 J/ Z' G; J2 ]* R* M( u
Dim rs As ADODB.Recordset
: w$ V2 F1 P# ^4 V' _7 P, A) W. . .
0 R1 X+ a  P. F" ]4 @/ ]cmd1 = txtQuery.Text
: y1 q# Q6 i  k& {" i* iSet rs = New ADODB.Recordset
; x) v- T6 Q+ g+ p8 ]- C5 N7 {9 X( q3 Srs.Properties("Command Time Out") = 300
+ S: F% i: A$ _% t9 Z# q'同样以秒为单位,如果设置为 0 表示无限制5 z; _0 I0 g$ B
rs.Open cmd1, cn
0 }! S7 F( u- r. Q3 f  X% ~rs.MoveFirst
0 p3 p/ C& D5 G4 f' u. . . </P><>6 Y+ p/ j5 R( \) K
  <B>三、小结</B>
+ I: {; e* x' \6 q+ i# X9 P4 l. ^" a0 S" l
* M- \' E8 e/ i9 A  本文针对大部分用户在使用 SQL Server 过程中常见的连接失败的错误,重点讨论了在使用 SQL Server 客户端工具以及用户开发的应用程序两种情况下,如何诊断并解决连接失败的错误。看过本文以后,相信每一个读者都会对 SQL Server 的连接工作原理、身份验证方式以及应用程序开发等有一个较为全面而深入的连接。本文中所有的测试或者示例均在 Windows 2000 Advanced Server + SQL Server 2000 企业版上通过。</P>
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册地址

qq
收缩
  • 电话咨询

  • 04714969085
fastpost

关于我们| 联系我们| 诚征英才| 对外合作| 产品服务| QQ

手机版|Archiver| |繁體中文 手机客户端  

蒙公网安备 15010502000194号

Powered by Discuz! X2.5   © 2001-2013 数学建模网-数学中国 ( 蒙ICP备14002410号-3 蒙BBS备-0002号 )     论坛法律顾问:王兆丰

GMT+8, 2026-10-9 03:04 , Processed in 1.494887 second(s), 58 queries .

回顶部