- 在线时间
- 0 小时
- 最后登录
- 2007-9-23
- 注册时间
- 2004-9-10
- 听众数
- 3
- 收听数
- 0
- 能力
- 0 分
- 体力
- 9975 点
- 威望
- 7 点
- 阅读权限
- 150
- 积分
- 4048
- 相册
- 0
- 日志
- 0
- 记录
- 0
- 帖子
- 1893
- 主题
- 823
- 精华
- 2
- 分享
- 0
- 好友
- 0

我的地盘我做主
该用户从未签到
|
单击"别名"选项卡,还可以为服务器配置别名。服务器的别名是用来连接的名称,连接参数中的服务器是真正的服务器名称,两者可以相同或不同。如下图中,我们可以使用myserver来代替真正的服务器名称sql2kcn-02,并且使用网络库 Named Pipes。别名的设置与使用HOSTS文件有相似之处。
- h$ c: t' M) X6 O6 t' F b
8 H8 p3 ~( ]" G% R. W) f2 K8 P
+ _+ i8 P9 D5 S. K通过以上几个方面的检查,错误 1 发生的原因基本上可以被排除。下面我们再详细描述如何来解决错误 2。" M- M) L/ t0 u, V I" D3 s
9 H1 D; T( q6 | 当用户尝试在查询分析器里面使用sa来连接SQL Server,或者在企业管理器里面使用sa来新建一个SQL Server注册时,经常会遇到如图 2 所示的错误信息。该错误产生的原因是由于SQL Server使用了"仅 Windows"的身份验证方式,因此用户无法使用SQL Server的登录帐户(如 sa )进行连接。解决方法如下所示:
( h. C% l$ e: t: V) b5 N0 }* L" G; `0 j8 C- x( z6 W Y5 ~
1、 在服务器端使用企业管理器,并且选择"使用 Windows 身份验证"连接上 SQL Server;
. v( L! D$ ]$ ]% M8 d0 N( Z6 I, b4 R% C1 x' y( c, T. P
2、 展开"SQL Server组",鼠标右键点击SQL Server服务器的名称,选择"属性",再选择"安全性"选项卡;
7 w/ z* B' b1 J$ E7 b
4 j( r) Q6 D* R- ]1 \8 J 3、 在"身份验证"下,选择"SQL Server和 Windows "。
( k r; j* L" O* M! s" a; v( _/ B4 D8 e( \" R; g; i& @
4、 重新启动SQL Server服务。
. X5 e$ ]. `* c; X9 S
2 R2 z4 _6 r# `1 @' f+ Q! g: W 在以上解决方法中,如果在第 1 步中使用"使用 Windows 身份验证"连接 SQL Server 失败,那么我们将遇到一个两难的境地:首先,服务器只允许了 Windows 的身份验证;其次,即使使用了 Windows 身份验证仍然无法连接上服务器。这种情形被形象地称之为"自己把自己锁在了门外",因为无论用何种方式,用户均无法使用进行连接。实际上,我们可以通过修改一个注册表键值来将身份验证方式改为 SQL Server 和 Windows 混合验证,步骤如下所示:
7 G6 W7 Q+ F) p% Z: h+ v2 d
6 U: f1 L, ~# n$ Y 1、点击"开始"-"运行",输入regedit,回车进入注册表编辑器;
9 [9 M3 {% k9 p2 {9 ~" {
( t# o' N8 _) a& N: @ 2、依次展开注册表项,浏览到以下注册表键:
& N4 e$ k% S+ e6 k# M8 b
% u6 \5 P* I) E6 v[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]5 y W7 d9 t9 S) }1 N P( _
$ r& ?4 N% [' z f% r7 s/ _ 3、在屏幕右方找到名称"LoginMode",双击编辑双字节值;
2 a& q% y" G) X: z+ P: F' j& s# g4 ` ]! Y" K% f
4、将原值从1改为2,点击"确定";
* m* y! M! F3 J7 h3 m# ?% k. O
$ Z7 G7 o' ^* i& M4 ~ 5、关闭注册表编辑器;
* m0 o1 H# V7 D
: s3 i1 G: _! J0 `4 f; W: u* m! M 6、重新启动SQL Server服务。7 R/ x& D' o( \) ]- _- X3 r
# ?4 Y. d% Z- L" {: z
此时,用户可以成功地使用sa在企业管理器中新建SQL Server注册,但是仍然无法使用Windows身份验证模式来连接SQL Server。这是因为在 SQL Server 中有两个缺省的登录帐户:BUILTIN\Administrators 以及 <机器名>\Administrator 被删除。要恢复这两个帐户,可以使用以下的方法:
1 S% L2 r4 R% N6 r4 N; K3 G3 \# z7 x
1、打开企业管理器,展开服务器组,然后展开服务器;
; K( |& C; k; z2 m0 k* p# Z4 ?1 e$ `# |1 I
2、展开"安全性",右击"登录",然后单击"新建登录";8 ?! b3 @ G6 h
' G( }3 ~( z' e& J: j* D' l6 M# e
3、在"名称"框中,输入 BUILTIN\Administrators;
4 C& S e- S" O6 @0 Z+ b1 h1 G. m _5 d# h6 u
4、在"服务器角色"选项卡中,选择"System Administrators" ;
- X( O8 d. Y0 [+ q9 R5 d5 Q! L3 D
& K& U; Y5 {# D. |. _ 5、点击"确定"退出;
# [# k5 V" m3 T% {4 F2 w
7 c' a' K8 A" N1 t8 n% m 6、使用同样方法添加 <机器名>\Administrator 登录。
: [. f4 [9 {" Q& }1 A! K0 @3 F( B* Z$ v: d( O
以下注册表键3 ^( ]/ i% Z- V+ G) a
7 u( ^: ]8 p: X/ O7 HHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode! x& }. X) h8 P/ }' X
% T! m: P# E2 S2 v3 F
的值决定了SQL Server将采取何种身份验证模式。该值为1,表示使用Windows 身份验证模式;该值为2,表示使用混合模式(Windows 身份验证和 SQL Server 身份验证)。
b. P' x- A. o) Z5 P& g4 p' N1 X1 b
5 A% @+ {/ \* {9 k) u 看完如何解决前两个错误的方法之后,让我们来看一下如图 3 所示的第三个错误。
+ v" e& E8 \, |; G
; g. T' h/ h, S$ p; s: U" ~2 l 如果遇到第三个错误,一般而言表示客户端已经找到了这台服务器,并且可以进行连接,不过是由于连接的时间大于允许的时间而导致出错。这种情况一般会发生在当用户在Internet上运行企业管理器来注册另外一台同样在Internet上的服务器,并且是慢速连接时,有可能会导致以上的超时错误。有些情况下,由于局域网的网络问题,也会导致这样的错误。6 t. y' b5 i0 @
5 f( l) q: ?- D! N, `: b 要解决这样的错误,可以修改客户端的连接超时设置。默认情况下,通过企业管理器注册另外一台SQL Server的超时设置是 4 秒,而查询分析器是 15 秒(这也是为什么在企业管理器里发生错误的可能性比较大的原因)。具体步骤为:. Y, n2 c, K! P1 J0 {5 c
2 O; X8 e- Y" W2 X- h 1、在企业管理器中,选择菜单上的"工具",再选择"选项";
4 N" l4 I/ K, W1 B
/ }# X4 s- i+ {( P" k 2、在弹出的"SQL Server企业管理器属性"窗口中,点击"高级"选项卡;
. |, V; d( K2 Q4 X: D/ b0 n2 w
. H& n; e/ Y& m) Z0 T7 T. V 3、在"连接设置"下的"登录超时(秒)"右边的框中输入一个比较大的数字,如 20。8 I, R- _: K* H f
5 t) {" `; L- u {6 E7 N 查询分析器中也可以在同样位置进行设置。 < >2 k8 K9 ], B5 _; k; a
二、应用程序连接失败5 I5 N7 o; w. A6 c! v! m! x
+ }" B+ h$ s5 f% ^7 _) y 以上的三种错误信息都是发生在 SQL Server 自带的客户端工具中,在应用程序中我们也会遇到类似的错误信息,例如:
; B8 V2 d. A) p2 E. g$ b
; @( A3 l+ p! N. [: F( a9 zMicrosoft OLE DB Provider for SQL Server (0x80004005)6 R8 r' g& {! y5 e( {5 e
[DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found." G/ R3 m h( o$ s$ {5 `
) X3 k! [7 _7 T; GMicrosoft OLE DB Provider for SQL Server (0x80004005). n. W3 W1 P( X' U( l: \
用户 'sa' 登录失败。原因: 未与信任 SQL Server 连接相关联。9 A p5 @4 y& q5 Y1 ^2 z I
?4 B; G; U5 ]' E, s1 Z( E& R' |Microsoft OLE DB Provider for ODBC Drivers 错误 '80004005'.
* W. S( A0 v: ~5 k1 I( E[Microsoft][ODBC SQL Server Driver]超时已过期.- q; j+ x+ e( F; u
" l! }) p+ m, m* F 首先,让我们来详细看以下的示意图来了解一下使用 ODBC 和使用 OLE DB 连接 SQL Server 有什么不同之处。- d8 T& U0 i. E, M. B- ~8 k$ ~
# |9 Q! z7 L" v B4 T0 y
1 [; q/ V- m: E$ }5 f2 Q+ Y5 p. u1 Q4 {
' A1 T5 x) N, ^) y" D 从上图中,我们可以看出在实际使用中,应用程序创建和使用各种 ADO 对象,ADO 对象框架调用享用的 OLE DB 提供者。为了访问 SQL Server 数据库,OLE DB 提供了两种不同的方法:用于 SQL Server 的 OLE DB 提供者以及用于 ODBC 的 OLE DB 提供者。这两种不同的方法对应于两种不同的连接字符串,标准的连接字符串写法如下所示:: B' M, ^! k, z7 D" t
" g+ K+ d' G o$ U5 ?( C 1、使用用于 SQL Server 的 OLE DB 提供者:4 r5 n: E7 ^8 c4 k8 G
, {# J) d8 v- S( s 使用 SQL Server 身份验证:
7 ^+ X- ?, b( [- h9 C) a& @9 r
+ b( e8 U6 o- m* \3 [% OoConn.Open " rovider=sqloledb;" & _
" F; N* O% I; V- |"Data Source=myServerName;" & _2 T) M( b" e# c- A8 A
"Initial Catalog=myDatabaseName;" & _
* @5 p0 p& T" V) L9 g/ ]) K"User Id=myUsername;" & _( p7 m O' l, b. _% s
" assword=myPassword"3 h9 s# l. D7 q) J
3 B3 y( L8 D5 ^) K. J
使用 Windows 身份验证(信任连接):' e3 m* }" j' P8 w
0 ^; |. V$ Y. FoConn.Open " rovider=sqloledb;" & _
6 d3 F; X9 P( c0 t- e- _"Data Source=myServerName;" & _
& K$ s% c3 j1 y: Y& k+ R"Initial Catalog=myDatabaseName;" & _
& C7 V" l; w% ~3 q0 X"Integrated Security=SSPI". @ M6 Q: b$ q @( e
, p. \( K, S6 U 2、使用用于 ODBC 的 OLE DB 提供者(不使用 ODBC 数据源):/ ~, V8 J4 }' g0 k% o7 w/ U
. V# ~! p2 q2 I3 W# G6 |& N3 q
使用 SQL Server 身份验证:7 q9 Y4 Y, `& O! }5 ~. _4 T
, I6 M0 b! E* Q- ~) L( @8 VoConn.Open "Driver={SQL Server};" & _ 9 c" Q, G1 Y% r8 A/ {3 \1 f( w* _
"Server=MyServerName;" & _
8 B4 m3 n9 X1 J& o) A4 o0 F"Database=myDatabaseName;" & _3 ?$ W4 E( U9 E1 ]+ O
"Uid=myUsername;" & _; G( c' Q4 j z
" wd=myPassword"
% C* X" n" f7 _0 N7 {
# m0 n3 }) C: [0 p* }! G 使用 Windows 身份验证(信任连接):* W$ \1 a0 A6 [. _
* p* a e. x- O" {
oConn.Open "Driver={SQL Server};" & _
2 Z6 ^1 N/ Q1 m5 u. z* l# {( v"Server=MyServerName;" & _& w) V4 L: f2 k* v
"Database=myDatabaseName;" & _
, W, `: X8 ]4 c"Trusted_Connection=yes", j* |+ G! h' c; }4 n1 n4 A% K
1 O) t1 @: G% A$ z. T
3、使用用于 ODBC 的 OLE DB 提供者(使用 ODBC 数据源):
l6 M. r( s& P0 j0 x* ?, r
! R& m4 e& A7 `( b0 X! koConn.Open "DSN=mySystemDSN;" & _ % T7 X! I+ l: R' A+ e5 v
"Uid=myUsername;" & _ - M# n: B7 y7 Y# l- `
" wd=myPassword"
8 e) J [. r9 w* Q' u& f! D' Z! b7 v! T0 ~: y
如果遇到连接失败的情况,我们只要按照一中所示的方法,结合程序中的连接字符串进行检查,基本都能得到解决。另外,还有以下几个要注意的地方:
# `" N a& q, W6 V) X8 M6 X
1 j4 ^0 C; P8 |0 G 1、配置 ODBC 数据源时,点击"客户端"配置选项可以让我们指定连接使用的网络库、端口号等属性,如下图所示:; }( T6 ^; i6 Y) B4 o
; i3 \9 M7 a6 A
) Q1 T" |# r) E( G
" C0 g7 n' t- c
5 E, w8 r. O8 e+ i/ J0 `( A
6 y7 f2 x; A. C; ]1 ?7 r 2、如果遇到连接超时的错误,我们可以在程序中修改 Connection 对象的超时设置,再打开该连接。例如:
' `1 l& R8 j8 y/ P& @2 C& U- Z8 R9 f+ {" a* m8 ~- o
</P>< ><%. B: L- d8 s* p( _( F, a$ i8 W
Set Conn = Server.CreateObject("ADODB.Connection")
, g, z+ j. ^- o9 |; U9 KDSNtest="DRIVER={SQL Server};SERVER=ServerName;UID=USER WD=password;DATABASE=mydatabase"
4 }/ w. T* k& w. NConn. Properties("Connect Timeout") = 15 '以秒为单位) F* Z( Y, C; K! ^
Conn.open DSNtest
, i' V- s+ x% n! R%></P>< >+ G/ l& `0 E& q) F, F
3、如果遇到查询超时的错误,我们可以在程序中修改 Recordset 对象的超时设置,再打开结果集。例如:
" x$ j/ |* l9 T6 p8 Y C
3 f8 j2 k, i w+ _, ?</P>< >Dim cn As New ADODB.Connection* N6 a) u: n% r9 o9 c
Dim rs As ADODB.Recordset; ?' g: l! @1 V$ Z+ `; l" f( ]9 P
. . . ! Z% a) }' ?; H7 J; B: O* j
cmd1 = txtQuery.Text# {* i/ A& A" l8 E0 l
Set rs = New ADODB.Recordset
' B3 l! ^2 V( w) k6 b# s4 k* Y3 rrs.Properties("Command Time Out") = 300
: z2 I( L* A& J7 I'同样以秒为单位,如果设置为 0 表示无限制
: n% r# \ { }) ]rs.Open cmd1, cn- c4 r, u8 _* V
rs.MoveFirst0 V% \ O. D: Z+ V$ K+ a% d
. . . </P>< >& \" l" u: i: K' X. r& E, q3 z; h
<B>三、小结</B>
# n/ L& M* a8 g. C5 M# o$ S s' q2 D1 m/ A( r' r
本文针对大部分用户在使用 SQL Server 过程中常见的连接失败的错误,重点讨论了在使用 SQL Server 客户端工具以及用户开发的应用程序两种情况下,如何诊断并解决连接失败的错误。看过本文以后,相信每一个读者都会对 SQL Server 的连接工作原理、身份验证方式以及应用程序开发等有一个较为全面而深入的连接。本文中所有的测试或者示例均在 Windows 2000 Advanced Server + SQL Server 2000 企业版上通过。</P> |
|